ImageMapLayerProps Interface
JSON representation of an ImageMapLayerSettings.
@see - MapImagerySettings.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
formatId | string | Identifies the map layers source. | |
queryParams | { T } | undefined | List of query parameters that will get appended to the source. | |
subLayers | MapSubLayerProps[] | undefined | Source layers. | |
url | string | URL |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
name Inherited | string | CommonMapLayerProps | A user-friendly name for the layer. |
transparency Inherited | number | undefined | CommonMapLayerProps | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, |
transparentBackground Inherited | boolean | undefined | CommonMapLayerProps | True to indicate background is transparent. |
visible Inherited | boolean | undefined | CommonMapLayerProps | Controls visibility of layer. |
Defined in
- core/common/src/MapLayerSettings.ts Line 151
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.