CommonMapLayerProps Interface
JSON representation of properties common to both ImageMapLayerProps and ModelMapLayerProps.
@see MapImageryProps
Properties
Name | Type | Description | |
---|---|---|---|
name | string | A user-friendly name for the layer. | |
transparency | number | undefined | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, | |
transparentBackground | boolean | undefined | True to indicate background is transparent. | |
visible | boolean | undefined | Controls visibility of layer. |
Defined in
- core/common/src/MapLayerSettings.ts Line 129
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.