RenderGraphicTileTreeArgs Interface
Arguments supplied to createFromRenderGraphic.
Properties
Name | Type | Description | |
---|---|---|---|
getToolTip | (hit: HitDetail) => Promise<undefined | string | HTMLElement> | undefined | A function that returns a tooltip describing a pickable Feature inside your graphic when the user hovers the mouse over it. | |
graphic | RenderGraphic | The graphics that will be drawn by the TileTreeReference. | |
iModel | IModelConnection | The iModel with which to associate the TileTreeReference. | |
modelId | string | A transient Id to serve as the modelId, obtained from the iModel's TransientIdSequence. | |
planarClipMaskPriority | number | undefined | Optionally overrides the default planarClipMaskPriority. | |
viewFlags | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | undefined | Optional overrides for a subset of the Viewport's ViewFlags when drawing your graphic. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.