InputCollector Class

The InputCollector class can be used to implement a command for gathering input (ex. get a distance by snapping to 2 points) without affecting the state of the active primitive tool. An InputCollector will suspend the active PrimitiveTool and can be suspended by a ViewTool.

Extends

Extended by

Methods

Name Description
constructor(..._args: any[]): InputCollector    
exitTool(): Promise<void>    
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Invoked when the reset button is released.  
run(..._args: any[]): Promise<boolean> Run this instance of a Tool.  

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited InteractiveTool Used to receive property changes from UI.
beginDynamics(): void Inherited InteractiveTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited InteractiveTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited InteractiveTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited InteractiveTool Helper method for responding to a tool setting property value change by updating saved settings.
decorate(_context: DecorateContext): void Inherited InteractiveTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited InteractiveTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited InteractiveTool Call to terminate dynamics mode.
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited InteractiveTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited InteractiveTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited InteractiveTool Called to allow snapping to pickable decoration geometry.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited InteractiveTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited InteractiveTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited InteractiveTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate: booleantrue, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited InteractiveTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(_vp: ScreenViewport, _isSelectedViewChange: boolean): boolean Inherited InteractiveTool  
isValidLocation(_ev: BeButtonEvent, _isButtonEvent: boolean): boolean Inherited InteractiveTool  
onCleanup(): Promise<void> Inherited InteractiveTool Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited InteractiveTool Invoked when the data button is pressed.
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited InteractiveTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited InteractiveTool Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> Inherited InteractiveTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited InteractiveTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited InteractiveTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited InteractiveTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited InteractiveTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited InteractiveTool Invoked when the button is released after onMouseStartDrag.
onMouseMotion(_ev: BeButtonEvent): Promise<void> Inherited InteractiveTool Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited InteractiveTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited InteractiveTool Invoked when the mouse wheel moves.
onPostInstall(): Promise<void> Inherited InteractiveTool Override to execute additional logic after tool becomes active
onReinitialize(): Promise<void> Inherited InteractiveTool Override Call to reset tool to initial state
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited InteractiveTool Invoked when the reset button is pressed.
onSelectedViewportChanged(_previous: ScreenViewport, _current: ScreenViewport): void Inherited InteractiveTool Called when active view changes.
onSuspend(): Promise<void> Inherited InteractiveTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(_ev: BeTouchEvent): Promise<void> Inherited InteractiveTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(_ev: BeTouchEvent): Promise<void> Inherited InteractiveTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited InteractiveTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(_ev: BeTouchEvent): Promise<void> Inherited InteractiveTool Called when a touch point moves along the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited InteractiveTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited InteractiveTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited InteractiveTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUnsuspend(): Promise<void> Inherited InteractiveTool Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.
parseAndRun(..._args: string[]): Promise<boolean> Inherited InteractiveTool Run this instance of a tool using a series of string arguments.
reloadToolSettingsProperties(): void Inherited InteractiveTool Called by tool to inform UI to reload ToolSettings with new set of properties.
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited InteractiveTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited InteractiveTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited InteractiveTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited InteractiveTool Register this Tool class with the ToolRegistry.

Inherited properties

Name Type Inherited from Description
description Accessor Inherited ReadOnly string InteractiveTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string InteractiveTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string InteractiveTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string InteractiveTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string InteractiveTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean InteractiveTool If true, this Tool will not appear in the list from getToolList.
iconSpec Accessor Inherited ReadOnly string InteractiveTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string InteractiveTool The icon for this Tool.
isControlDown Accessor Inherited ReadOnly boolean InteractiveTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean InteractiveTool Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string InteractiveTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string InteractiveTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly undefined | number InteractiveTool The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number InteractiveTool The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string InteractiveTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean InteractiveTool Used to avoid sending tools up events for which they did not receive the down event.
toolId Accessor Inherited ReadOnly string InteractiveTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
toolId Static Inherited string InteractiveTool The unique string that identifies this tool.

Defined in

Last Updated: 14 November, 2024