DialogProperty<T> Class
DialogProperty is a generic helper class that assists working with properties used by UiLayoutDataProvider implementations (i.e. Tool Settings and Dynamic Dialogs).
Methods
Name | Description | |
---|---|---|
constructor<T>(description: PropertyDescription, _value: T, _displayValue?: string, _isDisabled?: boolean): DialogProperty<T> | ||
toDialogItem(editorPosition: EditorPosition, lockProperty?: DialogItem): DialogItem |
Properties
Name | Type | Description | |
---|---|---|---|
description | PropertyDescription | ||
dialogItemValue Accessor | DialogItemValue | ||
displayValue Accessor | undefined | string | ||
isDisabled Accessor | boolean | ||
item Accessor ReadOnly | DialogPropertyItem | ||
name Accessor ReadOnly | string | ||
syncItem Accessor ReadOnly | DialogPropertySyncItem | ||
value Accessor | T |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.