initLocateElements Method
Helper method for tools that need to locate existing elements. Initializes ElementLocateManager, changes the view cursor to locate, enables display of the locate circle, and sets the appropriate coordinate lock overrides.
initLocateElements(enableLocate: booleantrue, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void
@see changeLocateState
Parameter | Type | Description |
---|---|---|
enableLocate | boolean | |
enableSnap | boolean | |
cursor | string | |
coordLockOvr | CoordinateLockOverrides |
Returns - void
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.