ElementLocateManager Class
Methods
Name | Description | |
---|---|---|
constructor(): ElementLocateManager | ||
clear(): void | ||
doLocate(response: LocateResponse, newSearch: boolean, testPoint: Point3d, view: ScreenViewport, source: InputSource, filterHits: booleantrue): Promise<undefined | HitDetail> | ||
filterHit(hit: HitDetail, _action: LocateAction, out: LocateResponse): Promise<LocateFilterStatus> | ||
getNextHit(): undefined | HitDetail | ||
getPreLocatedHit(): undefined | HitDetail | return the current path from either the snapping logic or the pre-locating systems. | |
initLocateOptions(): void | ||
initToolLocate(): void | ||
onInitialized(): void | ||
setCurrHit(hit?: HitDetail): void | ||
setHitList(list?: HitList<HitDetail>): void | ||
get the full message key for a locate failure |
Properties
Name | Type | Description | |
---|---|---|---|
apertureInches Accessor ReadOnly | number | ||
currHit | HitDetail | undefined | ||
hitList | HitList<HitDetail> | undefined | ||
options Readonly | LocateOptions | ||
picker Readonly | ElementPicker | ||
touchApertureInches Accessor ReadOnly | number |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.