ElementPicker Class
Methods
Name | Description | |
---|---|---|
constructor(): ElementPicker | ||
doPick(vp: ScreenViewport, pickPointWorld: Point3d, pickRadiusView: number, options: LocateOptions, excludedElements?: Iterable<string, any, any>): number | Generate a list of elements that are close to a given point. | |
empty(): void | ||
getHit(i: number): undefined | HitDetail | Return a hit from the list of hits created the last time pickElements was called. | |
getHitList(takeOwnership: boolean): HitList<HitDetail> | return the HitList for the last Pick performed. | |
getNextHit(): undefined | HitDetail | ||
resetCurrentHit(): void | ||
testHit(hit: HitDetail, vp: ScreenViewport, pickPointWorld: Point3d, pickRadiusView: number, options: LocateOptions): boolean |
Properties
Name | Type | Description | |
---|---|---|---|
hitList | HitList<HitDetail> | undefined | ||
pickPointWorld Readonly | Point3d | ||
viewport | Viewport | undefined |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.