BeWheelEvent Class
A BeButtonEvent generated by movement of a mouse wheel.
@note wheel events include mouse location.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(props?: BeWheelEventProps): BeWheelEvent | ||
setFrom(src: BeWheelEvent): this | Copy the values from another BeButtonEvent into this BeButtonEvent |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(): this Inherited | BeButtonEvent | Make a copy of this BeButtonEvent. |
init(props: BeButtonEventProps): void Inherited | BeButtonEvent | Initialize the values of this BeButtonEvent. |
invalidate(): void Inherited | BeButtonEvent | Mark this BeButtonEvent as invalid. |
Properties
Name | Type | Description | |
---|---|---|---|
time | number | ||
wheelDelta | number |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
button Inherited | BeButton | BeButtonEvent | The mouse button that created this event. |
coordsFrom Inherited | CoordSource | BeButtonEvent | How the coordinate values were generated (either from an action by the user or from a program.) |
inputSource Inherited | InputSource | BeButtonEvent | Whether this event came from a pointing device (e.g. |
isAltKey Accessor Inherited ReadOnly | boolean | BeButtonEvent | Determine whether the alt key was pressed |
isControlKey Accessor Inherited ReadOnly | boolean | BeButtonEvent | Determine whether the control key was pressed |
isDoubleClick Inherited | boolean | BeButtonEvent | If true, this is the second down in a rapid double-click of the same button. |
isDown Inherited | boolean | BeButtonEvent | If true, this event was generated from a mouse-down transition, false from a button-up transition. |
isDragging Inherited | boolean | BeButtonEvent | If true, this event was created by pressing, holding, and then moving a mouse button. |
isShiftKey Accessor Inherited ReadOnly | boolean | BeButtonEvent | Determine whether the shift key was pressed |
isValid Accessor Inherited ReadOnly | boolean | BeButtonEvent | Determine whether this BeButtonEvent has valid data. |
keyModifiers Inherited | BeModifierKeys | BeButtonEvent | The keyboard modifiers that were pressed when the event was generated. |
point Accessor Inherited | Point3d | BeButtonEvent | The point for this event, in world coordinates. |
rawPoint Accessor Inherited | Point3d | BeButtonEvent | The raw (unadjusted) point for this event, in world coordinates. |
viewPoint Accessor Inherited | Point3d | BeButtonEvent | The point, in screen coordinates for this event. |
viewport Inherited | ScreenViewport | undefined | BeButtonEvent | The ScreenViewport from which this BeButtonEvent was generated. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.