BeButtonEventProps Interface
Properties for constructing a BeButtonEvent
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
button | BeButton | undefined | The mouse button for this event. | |
coordsFrom | CoordSource | undefined | How the coordinate values were generated (either from an action by the user or from a program.) | |
inputSource | InputSource | undefined | Whether this event came from a pointing device (e.g. | |
isDoubleClick | boolean | undefined | If true, this is the second down in a rapid double-click of the same button. | |
isDown | boolean | undefined | If true, this event was generated from a mouse-down transition, false from a button-up transition. | |
isDragging | boolean | undefined | If true, this event was created by pressing, holding, and then moving a mouse button. | |
keyModifiers | BeModifierKeys | undefined | ||
point | Point3d | undefined | The point for this event, in world coordinates. | |
rawPoint | Point3d | undefined | The raw (unadjusted) point for this event, in world coordinates. | |
viewPoint | Point3d | undefined | The point, in screen coordinates for this event. | |
viewport | ScreenViewport | undefined | The ScreenViewport for the BeButtonEvent. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.