getToolTip Method
Invoked before the locate tooltip is displayed to retrieve the information about the located element. Allows the tool to override the toolTip.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement>
@returns A Promise for the HTMLElement or string to describe the hit.
@note If you override this method, you may decide whether to call your superclass' implementation or not (it is not required).
Parameter | Type | Description |
---|---|---|
_hit | HitDetail |
Returns - Promise<string | HTMLElement>
A Promise for the HTMLElement or string to describe the hit.
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.