getDecorationGeometry Method
Called to allow snapping to pickable decoration geometry.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps
@note Snap geometry can be different from decoration geometry (ex. center point of a + symbol). Valid decoration geometry for snapping should be "stable" and not change based on the current cursor location.
Parameter | Type | Description |
---|---|---|
_hit | HitDetail |
Returns - undefined | GeometryStreamProps
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.