onMouseEndDrag Method
Invoked when the button is released after onMouseStartDrag.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled>
@note default placement tool behavior is to treat press, drag, and release of data button the same as click, click by calling onDataButtonDown.
@returns Yes if event completely handled by tool and event should not be passed on to the IdleTool.
Parameter | Type | Description |
---|---|---|
ev | BeButtonEvent |
Returns - Promise<EventHandled>
Yes if event completely handled by tool and event should not be passed on to the IdleTool.
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.