ModifyElementWithDynamicsTool Class

Edit tool base class for updating existing elements that use dynamics to show intermediate results.

Extends

Implements

Methods

Name Description
constructor(..._args: any[]): ModifyElementWithDynamicsTool    
addFeatureOverrides(overrides: FeatureSymbology.Overrides, _vp: Viewport): void Add to the supplied overrides any symbology overrides to be applied to the specified viewport.  
agendaAppearance(isDynamics: boolean): FeatureAppearance Protected    
clearGraphics(): void Protected    
createGraphics(ev: BeButtonEvent): Promise<void> Protected    
onAgendaModified(): Promise<void> Protected Sub-classes can override to be notified of ElementSetTool.agenda changes by other methods.  
onCleanup(): Promise<void> Make sure elements from ElementSetTool.agenda that aren't also from SelectionSet aren't left hilited.  
onDynamicFrame(_ev: BeButtonEvent, context: DynamicsContext): void Called to allow Tool to display dynamic elements.  
onMouseMotion(ev: BeButtonEvent): Promise<void> Make sure drag selection graphics are updated when mouse moves.  
onPostInstall(): Promise<void> Setup initial element state, prompts, check SelectionSet, etc.  
onSuspend(): Promise<void> Notification of a ViewTool or InputCollector starting and this tool is being suspended.  
onUnsuspend(): Promise<void> Restore tool assistance after no longer being suspended by either a ViewTool or InputCollector.  
updateAgendaAppearanceProvider(drop?: "true"): void Protected    

Inherited methods

Name Inherited from Description
acceptElementForOperation(id: string): Promise<boolean> Protected Inherited ModifyElementTool  
allowView(_vp: Viewport): boolean Protected Inherited ModifyElementTool  
applyAgendaOperation(ev: BeButtonEvent): Promise<boolean> Protected Inherited ModifyElementTool  
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited ModifyElementTool Used to receive property changes from UI.
autoLockTarget(): void Inherited ModifyElementTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void Inherited ModifyElementTool Call to initialize dynamics mode.
buildDragSelectAgenda(vp: Viewport, origin: Point3d, corner: Point3d, method: SelectionMethod, overlap: boolean): Promise<boolean> Protected Inherited ModifyElementTool Populate ElementSetTool.agenda by drag box or crossing line information.
buildLocateAgenda(hit: HitDetail): Promise<boolean> Protected Inherited ModifyElementTool Populate ElementSetTool.agenda from a HitDetail.
buildSelectionSetAgenda(ss: SelectionSet): Promise<boolean> Protected Inherited ModifyElementTool Populate ElementSetTool.agenda from a SelectionSet.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited ModifyElementTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited ModifyElementTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited ModifyElementTool Helper method for responding to a tool setting property value change by updating saved settings.
chooseNextHit(ev: BeButtonEvent): Promise<EventHandled> Protected Inherited ModifyElementTool Allow reset to cycle between elements identified for overlapping the locate circle.
decorate(context: DecorateContext): void Inherited ModifyElementTool Show graphics for when drag selection is active.
decorateSuspended(_context: DecorateContext): void Inherited ModifyElementTool Called to allow a suspended tool to display non-element decorations in overlay mode.
doAcceptElementForOperation(_id: string): Promise<boolean> Protected Inherited ModifyElementTool  
doLocate(ev: BeButtonEvent, newSearch: boolean): Promise<boolean> Protected Inherited ModifyElementTool Identify an element and update the element agenda.
doProcessSelectionSetImmediate(): Promise<void> Protected Inherited ModifyElementTool Support either ElementSetTool.requireAcceptForSelectionSetOperation or ElementSetTool.requireAcceptForSelectionSetDynamics returning false.
doUpdateElement(_props: GeometricElementProps): Promise<boolean> Protected Inherited ModifyElementTool  
endDynamics(): void Inherited ModifyElementTool Call to terminate dynamics mode.
exitTool(): Promise<void> Inherited ModifyElementTool  
filterHit(hit: HitDetail, out?: LocateResponse): Promise<LocateFilterStatus> Inherited ModifyElementTool Called from ElementSetTool.doLocate as well as auto-locate to accept or reject elements under the cursor.
gatherElements(ev: BeButtonEvent): Promise<undefined | EventHandled> Protected Inherited ModifyElementTool Collect element input until tool has a sufficient number to complete.
gatherInput(ev: BeButtonEvent): Promise<undefined | EventHandled> Protected Inherited ModifyElementTool Collect point input until tool has a sufficient number to complete.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited ModifyElementTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited ModifyElementTool Called to allow snapping to pickable decoration geometry.
getDragSelectCandidates(vp: Viewport, origin: Point3d, corner: Point3d, method: SelectionMethod, overlap: boolean): Promise<Id64Arg> Protected Inherited ModifyElementTool Get element ids to process from drag box or crossing line selection.
getElementProps(ev: BeButtonEvent): undefined | GeometricElementProps Protected Abstract Inherited ModifyElementTool  
getGeometryProps(ev: BeButtonEvent, isAccept: boolean): undefined | JsonGeometryStream | FlatBufferGeometryStream Protected Abstract Inherited ModifyElementTool  
getGroupIds(id: string): Promise<Id64Arg> Protected Inherited ModifyElementTool If the supplied element is part of an assembly, return all member ids.
getLocateCandidates(hit: HitDetail): Promise<Id64Arg> Protected Inherited ModifyElementTool Get element id(s) to process from a HitDetail already accepted by ElementSetTool.isElementValidForOperation.
getPrompt(): string Inherited ModifyElementTool Returns the prompt based on the tool's current state.
getSelectionSetCandidates(ss: SelectionSet): Promise<Id64Arg> Protected Inherited ModifyElementTool Get element ids to process from the active selection set.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited ModifyElementTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited ModifyElementTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initAgendaDynamics(): Promise<boolean> Protected Inherited ModifyElementTool  
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited ModifyElementTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited ModifyElementTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean Inherited ModifyElementTool Determine whether the supplied Viewport is compatible with this tool.
isElementIdValid(id: string, source: ModifyElementSource): boolean Protected Inherited ModifyElementTool Quick id validity check.
isElementValidForOperation(hit: HitDetail, out?: LocateResponse): Promise<boolean> Protected Inherited ModifyElementTool Sub-classes should override to apply tool specific filtering and to provide an explanation for rejection.
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited ModifyElementTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Inherited ModifyElementTool Invoked when the data button is pressed.
onDataButtonUp(ev: BeButtonEvent): Promise<EventHandled> Inherited ModifyElementTool Invoked when the data button is released.
onGeometryFilterChanged(): void Protected Inherited ModifyElementTool  
onInstall(): Promise<boolean> Inherited ModifyElementTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited ModifyElementTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited ModifyElementTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ModifyElementTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited ModifyElementTool Update prompts, cursor, graphics, etc.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited ModifyElementTool Support completing active drag selection on mouse end drag event and update ElementSetTool.agenda.
onMouseStartDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited ModifyElementTool Support initiating drag selection on mouse start drag event when ElementSetTool.allowDragSelect is true.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited ModifyElementTool Invoked when the mouse wheel moves.
onProcessComplete(): Promise<void> Protected Inherited ModifyElementTool Sub-classes can override to continue with current ElementSetTool.agenda or restart after processing has completed.
onRedoPreviousStep(): Promise<boolean> Inherited ModifyElementTool Called to reinstate to a previous tool state (ex.
onReinitialize(): Promise<void> Inherited ModifyElementTool Exit and start default tool when ElementSetTool.isSelectionSetModify is true to allow SelectionSet to be modified,
onResetButtonDown(ev: BeButtonEvent): Promise<EventHandled> Inherited ModifyElementTool Invoked when the reset button is pressed.
onResetButtonUp(ev: BeButtonEvent): Promise<EventHandled> Inherited ModifyElementTool Invoked when the reset button is released.
onRestartTool(): Promise<void> Abstract Inherited ModifyElementTool Called when an external event may invalidate the current tool's state.
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited ModifyElementTool Called when active view changes.
onTouchCancel(_ev: BeTouchEvent): Promise<void> Inherited ModifyElementTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(_ev: BeTouchEvent): Promise<void> Inherited ModifyElementTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited ModifyElementTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(_ev: BeTouchEvent): Promise<void> Inherited ModifyElementTool Called when a touch point moves along the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited ModifyElementTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited ModifyElementTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited ModifyElementTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> Inherited ModifyElementTool Called to reverse to a previous tool state (ex.
parseAndRun(..._args: string[]): Promise<boolean> Inherited ModifyElementTool Run this instance of a tool using a series of string arguments.
postFilterIds(arg: Id64Arg): Promise<Id64Arg> Protected Inherited ModifyElementTool  
processAgenda(ev: BeButtonEvent): Promise<void> Inherited ModifyElementTool Sub-classes that require and use the accept point should override to apply the tool operation to ElementSetTool.agenda.
processAgendaImmediate(): Promise<void> Protected Inherited ModifyElementTool Sub-classes that return false for ElementSetTool.requireAcceptForSelectionSetOperation should override to apply the tool operation to ElementSetTool.agenda.
processDataButton(ev: BeButtonEvent): Promise<EventHandled> Protected Inherited ModifyElementTool Orchestrates advancing the internal state of the tool on a data button event.
processResetButton(ev: BeButtonEvent): Promise<EventHandled> Protected Inherited ModifyElementTool Orchestrates updating the internal state of the tool on a reset button event.
provideToolAssistance(mainInstrText?: string, additionalInstr?: ToolAssistanceInstruction[]): void Protected Inherited ModifyElementTool Sub-classes should override to provide tool specific instructions.
reloadToolSettingsProperties(): void Inherited ModifyElementTool Called by tool to inform UI to reload ToolSettings with new set of properties.
requireWriteableTarget(): boolean Inherited ModifyElementTool Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements.
run(..._args: any[]): Promise<boolean> Inherited ModifyElementTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> Inherited ModifyElementTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
selectByPointsDecorate(context: DecorateContext): void Protected Inherited ModifyElementTool Display drag box and crossing line selection graphics.
selectByPointsEnd(ev: BeButtonEvent): Promise<boolean> Protected Inherited ModifyElementTool Finish drag selection and update ElementSetTool.agenda with any elements that may have been identified.
selectByPointsStart(ev: BeButtonEvent): Promise<boolean> Protected Inherited ModifyElementTool Initiate tool state for start of drag selection.
setPreferredElementSource(): void Protected Inherited ModifyElementTool Whether tool should operate on an existing selection set or instead prompt user to identity elements.
setupAccuDraw(): void Protected Inherited ModifyElementTool  
setupAndPromptForNextAction(): void Protected Inherited ModifyElementTool Setup auto-locate, AccuSnap, AccuDraw, and supply tool assistance.
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited ModifyElementTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited ModifyElementTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited ModifyElementTool Called to support operations on pickable decorations, like snapping.
useOverlapSelection(ev: BeButtonEvent): boolean Protected Inherited ModifyElementTool Whether drag box selection only identifies elements that are wholly inside or also allows those that overlap
wantProcessAgenda(_ev: BeButtonEvent): boolean Protected Inherited ModifyElementTool Whether the tool is ready for ElementSetTool.processAgenda to be called to complete the tool operation.
register(namespace?: string): void Static Inherited ModifyElementTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
_agendaAppearanceDefault Protected FeatureAppearance | undefined    
_agendaAppearanceDynamic Protected FeatureAppearance | undefined    
_firstResult Protected boolean    
_graphicsProvider Protected DynamicGraphicsProvider | undefined    
wantAccuSnap Accessor Protected ReadOnly boolean Whether ElementSetTool.setupAndPromptForNextAction should call AccuSnap.enableSnap for current tool phase.  
wantAgendaAppearanceOverride Accessor Protected ReadOnly boolean    
wantDynamics Accessor Protected ReadOnly boolean Whether to automatically start element dynamics after all required elements have been identified.  

Inherited properties

Name Type Inherited from Description
_checkedIds Protected Readonly Inherited Map<string, boolean> ModifyElementTool  
agenda Accessor Protected Inherited ReadOnly ElementAgenda ModifyElementTool Get the ElementAgenda the tool will operate on.
allowDragSelect Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether to allow element identification by drag box or crossing line selection.
allowGroups Accessor Protected Inherited ReadOnly boolean ModifyElementTool Support operations on groups/assemblies independent of selection scope.
allowSelectionSet Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether ElementSetTool.agenda should be populated from an active selection set.
anchorPoint Protected Inherited Point3d | undefined ModifyElementTool The accept point for a selection set, drag select, or final located element.
briefcase Accessor Inherited ReadOnly undefined | BriefcaseConnection ModifyElementTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase.
clearSelectionSet Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether to clear the active selection set for tools that return false for ElementSetTool.allowSelectionSet.
controlKeyContinuesSelection Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether to continue selection of additional elements by holding the ctrl key down.
controlKeyInvertsSelection Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether to invert selection of elements identified with the ctrl key held down.
currentElementCount Accessor Protected Inherited ReadOnly number ModifyElementTool Convenience method to get current count from ElementSetTool.agenda.
description Accessor Inherited ReadOnly string ModifyElementTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string ModifyElementTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
dragStartPoint Protected Inherited Point3d | undefined ModifyElementTool The button down location that initiated box or crossing line selection.
englishKeyin Accessor Static Inherited ReadOnly string ModifyElementTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string ModifyElementTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string ModifyElementTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean ModifyElementTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string ModifyElementTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string ModifyElementTool The icon for this Tool.
iModel Accessor Inherited ReadOnly IModelConnection ModifyElementTool Get the iModel on which this tool operates.
isControlDown Accessor Inherited ReadOnly boolean ModifyElementTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean ModifyElementTool Call to find out if dynamics are currently active.
isSelectByPoints Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether drag box or crossing line selection is currently active.
isSelectionSetModify Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether original source of elements being modified was the active selection set.
keyin Accessor Inherited ReadOnly string ModifyElementTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string ModifyElementTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly undefined | number ModifyElementTool The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number ModifyElementTool The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string ModifyElementTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean ModifyElementTool Used to avoid sending tools up events for which they did not receive the down event.
requireAcceptForSelectionSetDynamics Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether to begin dynamics for a selection set immediately or wait for a data button.
requireAcceptForSelectionSetOperation Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether a selection set should be processed immediately upon installation or require a data button to accept.
requiredElementCount Accessor Protected Inherited ReadOnly number ModifyElementTool Minimum required number of elements for tool to be able to complete.
shouldEnableLocate Accessor Protected Inherited ReadOnly boolean ModifyElementTool  
shouldEnableSnap Accessor Protected Inherited ReadOnly boolean ModifyElementTool  
targetIsLocked Inherited boolean ModifyElementTool  
targetModelId Accessor Inherited undefined | string ModifyElementTool  
targetView Inherited Viewport | undefined ModifyElementTool The viewport within which the tool operates.
toolId Accessor Inherited ReadOnly string ModifyElementTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
toolId Static Inherited string ModifyElementTool The unique string that identifies this tool.
wantAdditionalElements Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether tool is done identifying elements and is ready to move to the next phase.
wantAdditionalInput Accessor Protected Inherited ReadOnly boolean ModifyElementTool Whether the tool has gathered enough input to call ElementSetTool.processAgenda.
Sub-classes should override to check for additional point input they collected in ElementSetTool.wantProcessAgenda.

Defined in

Last Updated: 14 November, 2024