ElementAgenda Class
The ElementAgenda class is used by ElementSetTool to hold the collection of elements it will operate on and to manage their hilite state.
@see ElementSetTool
Methods
Name | Description | |
---|---|---|
constructor(iModel: IModelConnection): ElementAgenda | ||
add(arg: Id64Arg): boolean | Add elements to this agenda. | |
clear(): void | Empties the agenda and clears hilite state when manageHiliteState is true. | |
compressIds(): string | Create CompressedId64Set from agenda. | |
find(id: string): boolean | Return true if elementId is already in this agenda. | |
getSource(): ModifyElementSource | Get the source for the last group added to this agenda, if applicable. | |
has(id: string): boolean | Return true if elementId is already in this agenda. | |
invert(arg: Id64Arg): boolean | Add elements not currently in the agenda and remove elements currently in the agenda. | |
orderIds(): OrderedId64Array | Create OrderedId64Array from agenda. | |
popGroup(): void | Removes the last group of elements added to this agenda. | |
remove(arg: Id64Arg): boolean | ||
setSource(val: ModifyElementSource): void | Set the source for the last group added to this agenda. |
Properties
Name | Type | Description | |
---|---|---|---|
count Accessor ReadOnly | number | ||
elements Readonly | Id64Array | The IDs of the elements in this agenda. | |
groupMarks Readonly | GroupMark[] | The group source identifiers for the elements in this agenda. | |
iModel | IModelConnection | ||
isEmpty Accessor ReadOnly | boolean | ||
length Accessor ReadOnly | number | ||
manageHiliteState | boolean |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.