ElementSetTool Class
The ElementSetTool class is a specialization of PrimitiveTool designed to unify operations on sets of elements. Use to query or modify existing elements as well as to create new elements from existing elements. Basic tool sequence:
- Populate ElementSetTool.agenda with the element ids to query or modify.
- Gather any additional input and if requested, enable dynamics to preview result.
- Call processAgenda to apply operation to ElementSetTool.agenda.
- Call onProcessComplete to restart or exit. Common element sources:
- Pre-selected elements from an active SelectionSet.
- Clicking in a view to identify elements using ElementLocateManager.
- Drag box and crossing line selection. Default behavior:
- Identify a single element with left-click.
- Immediately apply operation.
- Restart. Sub-classes are required to opt-in to additional element sources, dynamics, AccuSnap, additional input, etc.
Extends
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): ElementSetTool | ||
buildDragSelectAgenda(vp: Viewport, origin: Point3d, corner: Point3d, method: SelectionMethod, overlap: boolean): Promise<boolean> Protected | Populate ElementSetTool.agenda by drag box or crossing line information. | |
buildLocateAgenda(hit: HitDetail): Promise<boolean> Protected | Populate ElementSetTool.agenda from a HitDetail. | |
buildSelectionSetAgenda(ss: SelectionSet): Promise<boolean> Protected | Populate ElementSetTool.agenda from a SelectionSet. | |
chooseNextHit(ev: BeButtonEvent): Promise<EventHandled> Protected | Allow reset to cycle between elements identified for overlapping the locate circle. | |
decorate(context: DecorateContext): void | Show graphics for when drag selection is active. | |
doLocate(ev: BeButtonEvent, newSearch: boolean): Promise<boolean> Protected | Identify an element and update the element agenda. | |
doProcessSelectionSetImmediate(): Promise<void> Protected | Support either requireAcceptForSelectionSetOperation or requireAcceptForSelectionSetDynamics returning false. | |
filterHit(hit: HitDetail, out?: LocateResponse): Promise<LocateFilterStatus> | Called from doLocate as well as auto-locate to accept or reject elements under the cursor. | |
gatherElements(ev: BeButtonEvent): Promise<undefined | EventHandled> Protected | Collect element input until tool has a sufficient number to complete. | |
gatherInput(ev: BeButtonEvent): Promise<undefined | EventHandled> Protected | Collect point input until tool has a sufficient number to complete. | |
getDragSelectCandidates(vp: Viewport, origin: Point3d, corner: Point3d, method: SelectionMethod, overlap: boolean): Promise<Id64Arg> Protected | Get element ids to process from drag box or crossing line selection. | |
getGroupIds(id: string): Promise<Id64Arg> Protected | If the supplied element is part of an assembly, return all member ids. | |
getLocateCandidates(hit: HitDetail): Promise<Id64Arg> Protected | Get element id(s) to process from a HitDetail already accepted by isElementValidForOperation. | |
getSelectionSetCandidates(ss: SelectionSet): Promise<Id64Arg> Protected | Get element ids to process from the active selection set. | |
initAgendaDynamics(): Promise<boolean> Protected | ||
isElementIdValid(id: string, source: ModifyElementSource): boolean Protected | Quick id validity check. | |
isElementValidForOperation(hit: HitDetail, _out?: LocateResponse): Promise<boolean> Protected | Sub-classes should override to apply tool specific filtering and to provide an explanation for rejection. | |
onAgendaModified(): Promise<void> Protected | Sub-classes can override to be notified of ElementSetTool.agenda changes by other methods. | |
onCleanup(): Promise<void> | Make sure elements from ElementSetTool.agenda that aren't also from SelectionSet aren't left hilited. | |
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> | Invoked when the data button is pressed. | |
onDataButtonUp(ev: BeButtonEvent): Promise<EventHandled> | Invoked when the data button is released. | |
onModifierKeyTransition(_wentDown: boolean, modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> | Update prompts, cursor, graphics, etc. | |
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> | Support completing active drag selection on mouse end drag event and update ElementSetTool.agenda. | |
onMouseMotion(ev: BeButtonEvent): Promise<void> | Make sure drag selection graphics are updated when mouse moves. | |
onMouseStartDrag(ev: BeButtonEvent): Promise<EventHandled> | Support initiating drag selection on mouse start drag event when allowDragSelect is true. | |
onPostInstall(): Promise<void> | Setup initial element state, prompts, check SelectionSet, etc. | |
onProcessComplete(): Promise<void> Protected | Sub-classes can override to continue with current ElementSetTool.agenda or restart after processing has completed. | |
onReinitialize(): Promise<void> | Exit and start default tool when isSelectionSetModify is true to allow SelectionSet to be modified, | |
onResetButtonDown(ev: BeButtonEvent): Promise<EventHandled> | Invoked when the reset button is pressed. | |
onResetButtonUp(ev: BeButtonEvent): Promise<EventHandled> | Invoked when the reset button is released. | |
onUnsuspend(): Promise<void> | Restore tool assistance after no longer being suspended by either a ViewTool or InputCollector. | |
processAgenda(_ev: BeButtonEvent): Promise<void> Protected | Sub-classes that require and use the accept point should override to apply the tool operation to ElementSetTool.agenda. | |
processAgendaImmediate(): Promise<void> Protected | Sub-classes that return false for requireAcceptForSelectionSetOperation should override to apply the tool operation to ElementSetTool.agenda. | |
processDataButton(ev: BeButtonEvent): Promise<EventHandled> Protected | Orchestrates advancing the internal state of the tool on a data button event. | |
processResetButton(ev: BeButtonEvent): Promise<EventHandled> Protected | Orchestrates updating the internal state of the tool on a reset button event. | |
provideToolAssistance(mainInstrText?: string, additionalInstr?: ToolAssistanceInstruction[]): void Protected | Sub-classes should override to provide tool specific instructions. | |
selectByPointsDecorate(context: DecorateContext): void Protected | Display drag box and crossing line selection graphics. | |
selectByPointsEnd(ev: BeButtonEvent): Promise<boolean> Protected | Finish drag selection and update ElementSetTool.agenda with any elements that may have been identified. | |
selectByPointsStart(ev: BeButtonEvent): Promise<boolean> Protected | Initiate tool state for start of drag selection. | |
setPreferredElementSource(): void Protected | Whether tool should operate on an existing selection set or instead prompt user to identity elements. | |
setupAndPromptForNextAction(): void Protected | Setup auto-locate, AccuSnap, AccuDraw, and supply tool assistance. | |
useOverlapSelection(ev: BeButtonEvent): boolean Protected | Whether drag box selection only identifies elements that are wholly inside or also allows those that overlap | |
wantProcessAgenda(_ev: BeButtonEvent): boolean Protected | Whether the tool is ready for processAgenda to be called to complete the tool operation. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> | PrimitiveTool | Used to receive property changes from UI. |
autoLockTarget(): void | PrimitiveTool | Called on data button down event to lock the tool to its current target model. |
beginDynamics(): void | PrimitiveTool | Call to initialize dynamics mode. |
bumpToolSetting(_settingIndex?: number): Promise<boolean> | PrimitiveTool | Used to "bump" the value of a tool setting. |
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | PrimitiveTool | Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled. |
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean | PrimitiveTool | Helper method for responding to a tool setting property value change by updating saved settings. |
decorateSuspended(_context: DecorateContext): void | PrimitiveTool | Called to allow a suspended tool to display non-element decorations in overlay mode. |
endDynamics(): void | PrimitiveTool | Call to terminate dynamics mode. |
exitTool(): Promise<void> | PrimitiveTool | |
getCurrentButtonEvent(ev: BeButtonEvent): void | PrimitiveTool | Fill the supplied button event from the current cursor location. |
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps | PrimitiveTool | Called to allow snapping to pickable decoration geometry. |
getPrompt(): string | PrimitiveTool | Returns the prompt based on the tool's current state. |
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> | PrimitiveTool | Override to return the property that is disabled/enabled if the supplied property is a lock property. |
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> | PrimitiveTool | Invoked before the locate tooltip is displayed to retrieve the information about the located element. |
initLocateElements(enableLocate: booleantrue, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | PrimitiveTool | Helper method for tools that need to locate existing elements. |
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void | PrimitiveTool | Helper method to establish initial values for tool setting properties from saved settings. |
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean | PrimitiveTool | Determine whether the supplied Viewport is compatible with this tool. |
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean | PrimitiveTool | Checks that the adjusted point from the supplied button event is within the project extents for spatial views. |
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void | PrimitiveTool | Called to allow Tool to display dynamic elements. |
onInstall(): Promise<boolean> | PrimitiveTool | Override to execute additional logic when tool is installed. |
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> | PrimitiveTool | Called when any key is pressed or released. |
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | PrimitiveTool | Invoked when the middle mouse button is pressed. |
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | PrimitiveTool | Invoked when the middle mouse button is released. |
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> | PrimitiveTool | Invoked when the mouse wheel moves. |
onRedoPreviousStep(): Promise<boolean> | PrimitiveTool | Called to reinstate to a previous tool state (ex. |
onRestartTool(): Promise<void> Abstract | PrimitiveTool | Called when an external event may invalidate the current tool's state. |
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> | PrimitiveTool | Called when active view changes. |
onSuspend(): Promise<void> | PrimitiveTool | Notification of a ViewTool or InputCollector starting and this tool is being suspended. |
onTouchCancel(_ev: BeTouchEvent): Promise<void> | PrimitiveTool | Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches. |
onTouchComplete(_ev: BeTouchEvent): Promise<void> | PrimitiveTool | Called when the last touch point is removed from the surface completing the current gesture. |
onTouchEnd(_ev: BeTouchEvent): Promise<void> | PrimitiveTool | Called when user removes a touch point by lifting a finger or stylus from the surface. |
onTouchMove(_ev: BeTouchEvent): Promise<void> | PrimitiveTool | Called when a touch point moves along the surface. |
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> | PrimitiveTool | Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap. |
onTouchStart(_ev: BeTouchEvent): Promise<void> | PrimitiveTool | Called when user adds a touch point by placing a finger or stylus on the surface. |
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> | PrimitiveTool | Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving. |
onUndoPreviousStep(): Promise<boolean> | PrimitiveTool | Called to reverse to a previous tool state (ex. |
parseAndRun(..._args: string[]): Promise<boolean> | PrimitiveTool | Run this instance of a tool using a series of string arguments. |
reloadToolSettingsProperties(): void | PrimitiveTool | Called by tool to inform UI to reload ToolSettings with new set of properties. |
requireWriteableTarget(): boolean | PrimitiveTool | Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements. |
run(..._args: any[]): Promise<boolean> | PrimitiveTool | Establish this tool as the active PrimitiveTool. |
saveChanges(): Promise<void> | PrimitiveTool | If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string. |
supplyToolSettingsProperties(): undefined | DialogItem[] | PrimitiveTool | Used to supply list of properties that can be used to generate ToolSettings. |
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void | PrimitiveTool | Called by tool to synchronize the UI with property changes made by tool. |
testDecorationHit(_id: string): boolean | PrimitiveTool | Called to support operations on pickable decorations, like snapping. |
register(namespace?: string): void Static | PrimitiveTool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
agenda Accessor Protected ReadOnly | ElementAgenda | Get the ElementAgenda the tool will operate on. | |
allowDragSelect Accessor Protected ReadOnly | boolean | Whether to allow element identification by drag box or crossing line selection. | |
allowGroups Accessor Protected ReadOnly | boolean | Support operations on groups/assemblies independent of selection scope. | |
allowSelectionSet Accessor Protected ReadOnly | boolean | Whether ElementSetTool.agenda should be populated from an active selection set. | |
anchorPoint Protected | Point3d | undefined | The accept point for a selection set, drag select, or final located element. | |
clearSelectionSet Accessor Protected ReadOnly | boolean | Whether to clear the active selection set for tools that return false for allowSelectionSet. | |
controlKeyContinuesSelection Accessor Protected ReadOnly | boolean | Whether to continue selection of additional elements by holding the ctrl key down. | |
controlKeyInvertsSelection Accessor Protected ReadOnly | boolean | Whether to invert selection of elements identified with the ctrl key held down. | |
currentElementCount Accessor Protected ReadOnly | number | Convenience method to get current count from ElementSetTool.agenda. | |
dragStartPoint Protected | Point3d | undefined | The button down location that initiated box or crossing line selection. | |
isSelectByPoints Accessor Protected ReadOnly | boolean | Whether drag box or crossing line selection is currently active. | |
isSelectionSetModify Accessor Protected ReadOnly | boolean | Whether original source of elements being modified was the active selection set. | |
requireAcceptForSelectionSetDynamics Accessor Protected ReadOnly | boolean | Whether to begin dynamics for a selection set immediately or wait for a data button. | |
requireAcceptForSelectionSetOperation Accessor Protected ReadOnly | boolean | Whether a selection set should be processed immediately upon installation or require a data button to accept. | |
requiredElementCount Accessor Protected ReadOnly | number | Minimum required number of elements for tool to be able to complete. | |
shouldEnableLocate Accessor Protected ReadOnly | boolean | ||
shouldEnableSnap Accessor Protected ReadOnly | boolean | ||
wantAccuSnap Accessor Protected ReadOnly | boolean | Whether setupAndPromptForNextAction should call enableSnap for current tool phase. | |
wantAdditionalElements Accessor Protected ReadOnly | boolean | Whether tool is done identifying elements and is ready to move to the next phase. | |
wantAdditionalInput Accessor Protected ReadOnly | boolean | Whether the tool has gathered enough input to call processAgenda. | |
wantDynamics Accessor Protected ReadOnly | boolean | Whether to automatically start element dynamics after all required elements have been identified. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
briefcase Accessor ReadOnly | undefined | BriefcaseConnection | PrimitiveTool | Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase. |
description Accessor ReadOnly | string | PrimitiveTool | Get the localized description string from this Tool's class |
description Accessor Static ReadOnly | string | PrimitiveTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, flyover is returned. |
englishKeyin Accessor Static ReadOnly | string | PrimitiveTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | PrimitiveTool | Get the localized flyover string from this Tool's class |
flyover Accessor Static ReadOnly | string | PrimitiveTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, keyin is returned. |
hidden Static | boolean | PrimitiveTool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | PrimitiveTool | Get the iconSpec from this Tool's class. |
iconSpec Static | string | PrimitiveTool | The icon for this Tool. |
iModel Accessor ReadOnly | IModelConnection | PrimitiveTool | Get the iModel on which this tool operates. |
isControlDown Accessor ReadOnly | boolean | PrimitiveTool | Convenience method to check whether control key is currently down without needing a button event. |
isDynamicsStarted Accessor ReadOnly | boolean | PrimitiveTool | Call to find out if dynamics are currently active. |
keyin Accessor ReadOnly | string | PrimitiveTool | Get the localized keyin string from this Tool's class |
keyin Accessor Static ReadOnly | string | PrimitiveTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
maxArgs Accessor Static ReadOnly | undefined | number | PrimitiveTool | The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum. If subclasses override parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor Static ReadOnly | number | PrimitiveTool | The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static | string | PrimitiveTool | The namespace that provides localized strings for this Tool. |
receivedDownEvent | boolean | PrimitiveTool | Used to avoid sending tools up events for which they did not receive the down event. |
targetIsLocked | boolean | PrimitiveTool | |
targetModelId Accessor | undefined | string | PrimitiveTool | |
targetView | Viewport | undefined | PrimitiveTool | The viewport within which the tool operates. |
toolId Accessor ReadOnly | string | PrimitiveTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolId Static | string | PrimitiveTool | The unique string that identifies this tool. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.