FeatureOverrideProvider Interface
An object that customizes the appearance of Features within a Viewport using Overrides. When the viewport needs to recreate the symbology overrides, it invokes the provider's addFeatureOverrides method. If necessary - for example, because of changes to some state from which the provider derives the overrides - the provider can request that the viewport recreate the overrides by calling setFeatureOverrideProviderChanged.
@see addFeatureOverrideProvider to register a provider with a viewport.
Implemented by
Methods
Name | Description | |
---|---|---|
addFeatureOverrides(overrides: FeatureSymbology.Overrides, viewport: Viewport): void | Add to the supplied overrides any symbology overrides to be applied to the specified viewport. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.