RenderSchedule.ModelTimelineBuilder Class

As part of a [[RenderSchedule.ScriptBuilder, assembles a ModelTimeline.

@see RenderSchedule.ScriptBuilder.addModelTimeline.

Extends

Methods

Name Description
constructor(modelId: string, obtainNextBatchId: () => number): RenderSchedule.ModelTimelineBuilder Constructor - typically not used directly.  
addElementTimeline(elementIds: string | Iterable<string, any, any>): RenderSchedule.ElementTimelineBuilder Add a new ElementTimeline to be applied to the specified elements.  
finish(): RenderSchedule.ModelTimelineProps Obtain the JSON representation of the ModelTimeline produced by this builder.  

Inherited methods

Name Inherited from Description
addColor(time: number, color: RgbColor | { blue: number, green: number, red: number }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void Inherited RenderSchedule.TimelineBuilder Append a new ColorEntry to the timeline.
addCuttingPlane(time: number, plane: { direction: Readonly<WritableXYAndZ>, hidden?: boolean, position: Readonly<WritableXYAndZ>, visible?: boolean }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void Inherited RenderSchedule.TimelineBuilder Append a new CuttingPlaneEntry to the timeline.
addTransform(time: number, transform: Readonly<Transform>, components?: { orientation: Point4d, pivot: Readonly<WritableXYAndZ>, position: Readonly<WritableXYAndZ> }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void Inherited RenderSchedule.TimelineBuilder Append a new TransformEntry to the timeline.
addVisibility(time: number, visibility: number, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void Inherited RenderSchedule.TimelineBuilder Append a new VisibilityEntry to the timeline.

Properties

Name Type Description
modelId Readonly string The Id of the model affected by this timeline.  

Inherited properties

Name Type Inherited from Description
color Inherited RenderSchedule.ColorEntryProps[] | undefined RenderSchedule.TimelineBuilder Timeline controlling color.
cuttingPlane Inherited RenderSchedule.CuttingPlaneEntryProps[] | undefined RenderSchedule.TimelineBuilder Timeline controlling clipping.
transform Inherited RenderSchedule.TransformEntryProps[] | undefined RenderSchedule.TimelineBuilder Timeline controlling position and orientation.
visibility Inherited RenderSchedule.VisibilityEntryProps[] | undefined RenderSchedule.TimelineBuilder Timeline controlling visibility.

Defined in

Last Updated: 14 November, 2024