RenderSchedule.ElementTimelineBuilder Class
As part of a ScriptBuilder, assembles a ElementTimeline.
@see RenderSchedule.ModelTimelineBuilder.addElementTimeline.
Extends
Methods
Name | Description | |
---|---|---|
constructor(batchId: number, elementIds: string): RenderSchedule.ElementTimelineBuilder | Constructor - typically not used directly. | |
finish(): RenderSchedule.ElementTimelineProps | Obtain the JSON representation of the ElementTimeline produced by this builder. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addColor(time: number, color: RgbColor | { blue: number, green: number, red: number }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void | RenderSchedule.TimelineBuilder | Append a new ColorEntry to the timeline. |
addCuttingPlane(time: number, plane: { direction: Readonly<WritableXYAndZ>, hidden?: boolean, position: Readonly<WritableXYAndZ>, visible?: boolean }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void | RenderSchedule.TimelineBuilder | Append a new CuttingPlaneEntry to the timeline. |
addTransform(time: number, transform: Readonly<Transform>, components?: { orientation: Point4d, pivot: Readonly<WritableXYAndZ>, position: Readonly<WritableXYAndZ> }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void | RenderSchedule.TimelineBuilder | Append a new TransformEntry to the timeline. |
addVisibility(time: number, visibility: number, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void | RenderSchedule.TimelineBuilder | Append a new VisibilityEntry to the timeline. |
Properties
Name | Type | Description | |
---|---|---|---|
batchId Readonly | number | A positive integer that uniquely identifies this timeline among all element timelines in the RenderSchedule.Script. | |
elementIds Readonly | string | The compressed set of Ids of the elements affected by this timeline. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
color | RenderSchedule.ColorEntryProps[] | undefined | RenderSchedule.TimelineBuilder | Timeline controlling color. |
cuttingPlane | RenderSchedule.CuttingPlaneEntryProps[] | undefined | RenderSchedule.TimelineBuilder | Timeline controlling clipping. |
transform | RenderSchedule.TransformEntryProps[] | undefined | RenderSchedule.TimelineBuilder | Timeline controlling position and orientation. |
visibility | RenderSchedule.VisibilityEntryProps[] | undefined | RenderSchedule.TimelineBuilder | Timeline controlling visibility. |
Defined in
- core/common/src/RenderSchedule.ts Line 1346
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.