RenderSchedule.ElementTimelineProps Interface
JSON representation of an ElementTimeline.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
batchId | number | A positive integer that uniquely identifies this timeline among all element timelines in the RenderSchedule.Script. | |
elementIds | string | string[] | The Ids of the elements to which this timeline applies. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
colorTimeline | RenderSchedule.ColorEntryProps[] | undefined | RenderSchedule.TimelineProps | Timeline controlling the colors of the associated geometry. |
cuttingPlaneTimeline | RenderSchedule.CuttingPlaneEntryProps[] | undefined | RenderSchedule.TimelineProps | Timeline applying ClipVectors to the associated geometry. |
transformTimeline | RenderSchedule.TransformEntryProps[] | undefined | RenderSchedule.TimelineProps | Timeline applying transforms to the associated geometry. |
visibilityTimeline | RenderSchedule.VisibilityEntryProps[] | undefined | RenderSchedule.TimelineProps | Timeline controlling the visibility of the associated geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 153
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.