RenderSchedule.TimelineProps Interface
JSON representation of a Timeline.
Properties
Name | Type | Description | |
---|---|---|---|
colorTimeline | RenderSchedule.ColorEntryProps[] | undefined | Timeline controlling the colors of the associated geometry. | |
cuttingPlaneTimeline | RenderSchedule.CuttingPlaneEntryProps[] | undefined | Timeline applying ClipVectors to the associated geometry. | |
transformTimeline | RenderSchedule.TransformEntryProps[] | undefined | Timeline applying transforms to the associated geometry. | |
visibilityTimeline | RenderSchedule.VisibilityEntryProps[] | undefined | Timeline controlling the visibility of the associated geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 141
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.