RenderSchedule.TimelineBuilder Class
Used as part of a ScriptBuilder to define a Timeline. Functions that append to the timeline expect entries to be appended in chronological order - i.e., you cannot append an entry that is earlier than a previously appended entry.
@see ElementTimelineBuilder and ModelTimelineBuilder.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): RenderSchedule.TimelineBuilder | ||
addColor(time: number, color: RgbColor | { blue: number, green: number, red: number }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void | Append a new ColorEntry to the timeline. | |
addCuttingPlane(time: number, plane: { direction: Readonly<WritableXYAndZ>, hidden?: boolean, position: Readonly<WritableXYAndZ>, visible?: boolean }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void | Append a new CuttingPlaneEntry to the timeline. | |
addTransform(time: number, transform: Readonly<Transform>, components?: { orientation: Point4d, pivot: Readonly<WritableXYAndZ>, position: Readonly<WritableXYAndZ> }, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void | Append a new TransformEntry to the timeline. | |
addVisibility(time: number, visibility: number, interpolation: RenderSchedule.InterpolationInterpolation.Linear): void | Append a new VisibilityEntry to the timeline. | |
finish(): RenderSchedule.TimelineProps | Obtain the JSON representation of the Timeline produced by this builder. |
Properties
Name | Type | Description | |
---|---|---|---|
color | RenderSchedule.ColorEntryProps[] | undefined | Timeline controlling color. | |
cuttingPlane | RenderSchedule.CuttingPlaneEntryProps[] | undefined | Timeline controlling clipping. | |
transform | RenderSchedule.TransformEntryProps[] | undefined | Timeline controlling position and orientation. | |
visibility | RenderSchedule.VisibilityEntryProps[] | undefined | Timeline controlling visibility. |
Defined in
- core/common/src/RenderSchedule.ts Line 1258
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.