RenderSchedule.ModelTimelineProps Interface
JSON representation of a ModelTimeline.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
elementTimelines | RenderSchedule.ElementTimelineProps[] | Timelines affecting groups of elements. | |
modelId | string | The Id of the GeometricModelState to which the timeline applies. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
colorTimeline | RenderSchedule.ColorEntryProps[] | undefined | RenderSchedule.TimelineProps | Timeline controlling the colors of the associated geometry. |
cuttingPlaneTimeline | RenderSchedule.CuttingPlaneEntryProps[] | undefined | RenderSchedule.TimelineProps | Timeline applying ClipVectors to the associated geometry. |
transformTimeline | RenderSchedule.TransformEntryProps[] | undefined | RenderSchedule.TimelineProps | Timeline applying transforms to the associated geometry. |
visibilityTimeline | RenderSchedule.VisibilityEntryProps[] | undefined | RenderSchedule.TimelineProps | Timeline controlling the visibility of the associated geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 165
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.