GeometricModelState Class
Represents the front-end state of a GeometricModel. The contents of a GeometricModelState can be rendered inside a Viewport.
Extends
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: GeometricModelProps, iModel: IModelConnection, state?: GeometricModelState): GeometricModelState | ||
queryModelRange(): Promise<Range3d> | Query for the union of the ranges of all the elements in this GeometricModel. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): this Inherited | ModelState | Make an independent copy of this EntityState |
equals(other: this): boolean Inherited | ModelState | Return true if this EntityState is equal to another one. |
toJSON(): ModelProps Inherited | ModelState | Add all custom-handled properties of a Model to a json object. |
Properties
Name | Type | Description | |
---|---|---|---|
asGeometricModel Accessor ReadOnly | GeometricModelState | Attempts to cast this model to a geometric model. | |
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. | |
is2d Accessor ReadOnly | boolean | Returns true if this is a 2d model (a GeometricModel2dState). | |
is3d Accessor Abstract ReadOnly | boolean | Returns true if this is a 3d model (a GeometricModel3dState). | |
isGeometricModel Accessor ReadOnly | boolean | Determine whether this is a GeometricModel |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel2d Accessor Inherited ReadOnly | undefined | GeometricModel2dState | ModelState | Attempts to cast this model to a 2d geometric model. |
asGeometricModel3d Accessor Inherited ReadOnly | undefined | GeometricModel3dState | ModelState | Attempts to cast this model to a 3d geometric model. |
asSpatialModel Accessor Inherited ReadOnly | undefined | SpatialModelState | ModelState | Attempts to cast this model to a spatial model. |
classFullName Accessor Static Inherited ReadOnly | string | ModelState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly Inherited | string | ModelState | The full class name in the form "schema:class". |
className Accessor Inherited ReadOnly | string | ModelState | The name of the BIS class associated with this class. |
id Readonly Inherited | string | ModelState | The Id of this Entity. |
iModel Readonly Inherited | IModelConnection | ModelState | The iModel from which this Entity was loaded |
isPrivate Readonly Inherited | boolean | ModelState | |
isTemplate Readonly Inherited | boolean | ModelState | |
jsonProperties Readonly Inherited | { T } | ModelState | Optional json properties of this Entity. |
modeledElement Readonly Inherited | RelatedElement | ModelState | |
name Readonly Inherited | string | ModelState | |
parentModel Inherited | string | ModelState | |
schemaName Accessor Static Inherited ReadOnly | string | ModelState | The name of the BIS schema for this class. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.