GeometricModel3dState Class
Represents the front-end state of a GeometricModel3d.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: GeometricModel3dProps, iModel: IModelConnection, state?: GeometricModel3dState): GeometricModel3dState | ||
toJSON(): GeometricModel3dProps | Add all custom-handled properties of a Model to a json object. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): this Inherited | GeometricModelState | Make an independent copy of this EntityState |
equals(other: this): boolean Inherited | GeometricModelState | Return true if this EntityState is equal to another one. |
queryModelRange(): Promise<Range3d> Inherited | GeometricModelState | Query for the union of the ranges of all the elements in this GeometricModel. |
Properties
Name | Type | Description | |
---|---|---|---|
asGeometricModel3d Accessor ReadOnly | GeometricModel3dState | Attempts to cast this model to a 3d geometric model. | |
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. | |
is3d Accessor ReadOnly | boolean | Returns true if this is a 3d model (a GeometricModel3dState). | |
isNotSpatiallyLocated Readonly | boolean | If true, then the elements in this GeometricModel3dState are not in real-world coordinates and will not be in the spatial index. | |
isPlanProjection Readonly | boolean | If true, then the elements in this GeometricModel3dState are expected to be in an XY plane. | |
isSpatiallyLocated Accessor ReadOnly | boolean | If true, then the elements in this GeometricModel3dState are in real-world coordinates and will be in the spatial index. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel Accessor Inherited ReadOnly | GeometricModelState | GeometricModelState | Attempts to cast this model to a geometric model. |
asGeometricModel2d Accessor Inherited ReadOnly | undefined | GeometricModel2dState | GeometricModelState | Attempts to cast this model to a 2d geometric model. |
asSpatialModel Accessor Inherited ReadOnly | undefined | SpatialModelState | GeometricModelState | Attempts to cast this model to a spatial model. |
classFullName Accessor Static Inherited ReadOnly | string | GeometricModelState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly Inherited | string | GeometricModelState | The full class name in the form "schema:class". |
className Accessor Inherited ReadOnly | string | GeometricModelState | The name of the BIS class associated with this class. |
id Readonly Inherited | string | GeometricModelState | The Id of this Entity. |
iModel Readonly Inherited | IModelConnection | GeometricModelState | The iModel from which this Entity was loaded |
is2d Accessor Inherited ReadOnly | boolean | GeometricModelState | Returns true if this is a 2d model (a GeometricModel2dState). |
isGeometricModel Accessor Inherited ReadOnly | boolean | GeometricModelState | Determine whether this is a GeometricModel |
isPrivate Readonly Inherited | boolean | GeometricModelState | |
isTemplate Readonly Inherited | boolean | GeometricModelState | |
jsonProperties Readonly Inherited | { T } | GeometricModelState | Optional json properties of this Entity. |
modeledElement Readonly Inherited | RelatedElement | GeometricModelState | |
name Readonly Inherited | string | GeometricModelState | |
parentModel Inherited | string | GeometricModelState | |
schemaName Accessor Static Inherited ReadOnly | string | GeometricModelState | The name of the BIS schema for this class. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.