SectionDrawingLocationState Class
Represents a SectionDrawingLocation, including data from related elements like SectionDrawing used in a hyper-modeling context.
@see SectionMarker for a widget that allows the user to interact with a section drawing location.
Methods
Name | Description | |
---|---|---|
tryLoadDrawingView(): Promise<undefined | DrawingViewState> | Return a promise that resolves to the DrawingViewState corresponding to this.drawingViewId , or undefined if an exception occurs. |
|
tryLoadSheetView(): Promise<undefined | SheetViewState> | Return a promise that resolves to the SheetViewState corresponding to this.viewAttachment.viewId ; or undefined if there is no corresponding ViewAttachment or an exception occurs. |
|
tryLoadSpatialView(): Promise<undefined | SpatialViewState> | Return a promise that resolves to the SpatialViewState corresponding to this.spatialViewId , or undefined if an exception occurs. |
|
queryAll(iModel: IModelConnection): Promise<SectionDrawingLocationState[]> Static | Query the specified iModel for SectionDrawingLocations and return a list of corresponding SectionDrawingLocationStates. |
Properties
Name | Type | Description | |
---|---|---|---|
category Readonly | string | The Id of the SpatialCategory to which this section drawing location belongs. | |
clip Readonly | ClipVector | The section clip from the SpatialViewDefinition from which the section drawing was generated. | |
drawingToSpatialTransform Readonly | Transform | The transform from the GeometricModel containing the section graphics to the spatial coordinate space. | |
drawingViewId Readonly | string | The Id of the ViewDefinition that can display the section graphics. | |
id Readonly | string | The element Id of the section drawing location. | |
iModel Readonly | IModelConnection | The iModel in which this section drawing location resides. | |
model Readonly | string | The Id of the GeometricModel3d in which this section drawing location resides. | |
placement Readonly | Placement3d | The section drawing location's spatial placement. | |
sectionType Readonly | SectionType | The type of section that generated the associated SectionDrawing. | |
spatialViewId Readonly | string | The Id of the SpatialViewDefinition from which the section drawing was generated. | |
userLabel Readonly | string | A user-friendly label for the section drawing location. | |
viewAttachment Readonly | SectionViewAttachment | undefined | If the section drawing is attached to a Sheet, details about the corresponding ViewAttachment. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.