SectionViewAttachment Interface
Represents a ViewAttachment that attaches a SectionDrawingLocationState to a Sheet model.
Properties
Name | Type | Description | |
---|---|---|---|
clip Readonly | ClipVector | undefined | Optional 2d clip vector used to clip out portions of the Sheet containing annotations not relevant to this section drawing. | |
id Readonly | string | The view attachment's element Id. | |
transformToSpatial Readonly | Transform | The transform from the Sheet coordinate space to the spatial coordinate space. | |
viewId Readonly | string | undefined | The Id of a SheetViewDefinition that displays this view attachment. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.