SpatialCategory Class

Categorizes SpatialElements. See how to create a SpatialCategory.

Extends

Methods

Name Description
constructor(opts: ElementProps, iModel: IModelDb): SpatialCategory Protected    
create(iModelDb: IModelDb, definitionModelId: string, name: string): SpatialCategory Static Create a new SpatialCategory  
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static Create a Code for a SpatialCategory given a name that is meant to be unique within the scope of the specified DefinitionModel.  
getCodeSpecName(): string Static Get the name of the CodeSpec that is used by SpatialCategory objects.  
insert(iModelDb: IModelDb, definitionModelId: string, name: string, defaultAppearance: SubCategoryAppearance | SubCategoryAppearance.Props): string Static Insert a new SpatialCategory  
queryCategoryIdByName(iModel: IModelDb, scopeModelId: string, categoryName: string): undefined | string Static Looks up the CategoryId of a SpatialCategory by model and name  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited Category Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited Category Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited Category Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited Category Call a function for each property of this Entity.
Category Get the class metadata for this element.
getDisplayLabel(): string Inherited Category Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited Category Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited Category Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited Category Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited Category Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited Category Get a set of JSON user properties by namespace
insert(): string Inherited Category Insert this Element into the iModel.
myDefaultSubCategoryId(): string Inherited Category Get the Id of the default SubCategory for this Category.
removeUserProperties(nameSpace: string): void Inherited Category Remove a set of JSON user properties, specified by namespace, from this Element
setDefaultAppearance(props: SubCategoryAppearance | SubCategoryAppearance.Props): void Inherited Category Set the appearance of the default SubCategory for this Category
setJsonProperty(nameSpace: string, value: any): void Inherited Category  
setUserProperties(nameSpace: string, value: any): void Inherited Category Change a set of user JSON properties of this Element by namespace.
toJSON(): CategoryProps Inherited Category Obtain the JSON representation of this Entity.
update(): void Inherited Category Update this Element in the iModel.
is(otherClass: ): boolean Static Inherited Category return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited Category Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited Category Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited Category Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited Category Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited Category Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited Category Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited Category Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited Category Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited Category Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited Category Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited Category Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited Category Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited Category Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited Category Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited Category Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited Category Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited Category Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited Category Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited Category Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited Category Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited Category Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited Category Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited Category Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string Category Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string Category Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string Category The name of the BIS class associated with this class.
code Inherited Code Category The Code for this element
description Inherited string | undefined Category  
federationGuid Inherited string | undefined Category A FederationGuid assigned to this element by some other federated database
id Inherited string Category The Id of this Entity.
iModel Inherited IModelDb Category The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" Category An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean Category If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly Inherited { T } Category Optional json properties of this element.
model Readonly Inherited string Category The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined Category The parent element, if present, of this element.
rank Inherited Rank Category  
requiredReferenceKeys Static Readonly Inherited ReadonlyArray Category A required reference is an element that had to be inserted before this element could have been inserted.
schema Static Inherited Category The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string Category The name of the BIS Schema that defines this class
userLabel Inherited string | undefined Category A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024