RenderSchedule.Timeline Class
Specifies how to animate a set of geometry over time within a RenderSchedule.Script. A RenderSchedule.Script can contain any number of Timelines, each affecting different sets of geometry.
@see ElementTimeline and ModelTimeline.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: RenderSchedule.TimelineProps): RenderSchedule.Timeline | ||
compareTo(other: RenderSchedule.Timeline): number | ||
equals(other: RenderSchedule.Timeline): boolean | ||
getAnimationTransform(time: number): Readonly<Transform> | Get the transform applied to the geometry at the specified time point. | |
getClipVector(time: number): undefined | ClipVector | Create a ClipVector from the CuttingPlane applied to the geometry at the specified time point, if any. | |
getColor(time: number): undefined | RgbColor | Get the color of the geometry at the specified time point, or undefined if the color is not overridden at that time point. | |
getCuttingPlane(time: number): undefined | Plane3dByOriginAndUnitNormal | Get the clipping plane applied to the geometry at the specified time point, or undefined if the geometry is unclipped at that time point. | |
getVisibility(time: number): number | Get the visibility of the geometry at the specified time point. | |
toJSON(): RenderSchedule.TimelineProps |
Properties
Name | Type | Description | |
---|---|---|---|
color Readonly | RenderSchedule.TimelineEntryList<RenderSchedule.ColorEntry, RenderSchedule.ColorEntryProps, undefined | RgbColor> | undefined | Sequence controlling the color of the geometry. | |
cuttingPlane Readonly | RenderSchedule.TimelineEntryList<RenderSchedule.CuttingPlaneEntry, RenderSchedule.CuttingPlaneEntryProps, undefined | RenderSchedule.CuttingPlane> | undefined | Sequence controlling how the geometry is clipped. | |
duration Readonly | Range1d | The total time period represented by this timeline. | |
transform Readonly | RenderSchedule.TransformTimelineEntries | undefined | Sequence controlling the position, orientation, and/or scale of the geometry. | |
visibility Readonly | RenderSchedule.VisibilityTimelineEntries | undefined | Sequence controlling the visibility of the geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 560
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.