RenderSchedule.CuttingPlane Class
Defines a ClipPlane associated with a CuttingPlaneEntry.
Methods
Name | Description | |
---|---|---|
constructor(props: RenderSchedule.CuttingPlaneProps): RenderSchedule.CuttingPlane | ||
compareTo(other: RenderSchedule.CuttingPlane): number | ||
equals(other: RenderSchedule.CuttingPlane): boolean | ||
toJSON(): RenderSchedule.CuttingPlaneProps |
Properties
Name | Type | Description | |
---|---|---|---|
direction Readonly | Readonly<WritableXYAndZ> | The direction perpendicular to the plane pointing toward the clip. | |
hidden Readonly | boolean | If true, the clip plane is ignored and the geometry is always clipped. | |
position Readonly | Readonly<WritableXYAndZ> | A point on the plane. | |
visible Readonly | boolean | If true, the clip plane is ignored and the geometry is never clipped. |
Defined in
- core/common/src/RenderSchedule.ts Line 356
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.