RenderSchedule.ElementTimeline Class
Specifies how to animate the geometry belonging to a set of GeometricElements as part of a RenderSchedule.Script.
Extends
Methods
Name | Description | |
---|---|---|
compareTo(other: RenderSchedule.ElementTimeline): number | ||
toJSON(): RenderSchedule.ElementTimelineProps | ||
fromJSON(props?: RenderSchedule.ElementTimelineProps): RenderSchedule.ElementTimeline Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equals(other: RenderSchedule.Timeline): boolean | RenderSchedule.Timeline | |
getAnimationTransform(time: number): Readonly<Transform> | RenderSchedule.Timeline | Get the transform applied to the geometry at the specified time point. |
getClipVector(time: number): undefined | ClipVector | RenderSchedule.Timeline | Create a ClipVector from the CuttingPlane applied to the geometry at the specified time point, if any. |
getColor(time: number): undefined | RgbColor | RenderSchedule.Timeline | Get the color of the geometry at the specified time point, or undefined if the color is not overridden at that time point. |
getCuttingPlane(time: number): undefined | Plane3dByOriginAndUnitNormal | RenderSchedule.Timeline | Get the clipping plane applied to the geometry at the specified time point, or undefined if the geometry is unclipped at that time point. |
getVisibility(time: number): number | RenderSchedule.Timeline | Get the visibility of the geometry at the specified time point. |
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
color Readonly | RenderSchedule.TimelineEntryList<RenderSchedule.ColorEntry, RenderSchedule.ColorEntryProps, undefined | RgbColor> | undefined | RenderSchedule.Timeline | Sequence controlling the color of the geometry. |
cuttingPlane Readonly | RenderSchedule.TimelineEntryList<RenderSchedule.CuttingPlaneEntry, RenderSchedule.CuttingPlaneEntryProps, undefined | RenderSchedule.CuttingPlane> | undefined | RenderSchedule.Timeline | Sequence controlling how the geometry is clipped. |
duration Readonly | Range1d | RenderSchedule.Timeline | The total time period represented by this timeline. |
transform Readonly | RenderSchedule.TransformTimelineEntries | undefined | RenderSchedule.Timeline | Sequence controlling the position, orientation, and/or scale of the geometry. |
visibility Readonly | RenderSchedule.VisibilityTimelineEntries | undefined | RenderSchedule.Timeline | Sequence controlling the visibility of the geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 741
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.