RenderSchedule.ModelTimeline Class
Specifies how to animate the geometry within a GeometricModel as part of a RenderSchedule.Script.
Extends
Methods
Name | Description | |
---|---|---|
compareTo(other: RenderSchedule.ModelTimeline): number | ||
findByBatchId(batchId: number): undefined | RenderSchedule.ElementTimeline | Look up the element timeline with the specified batch Id. | |
getTransform(batchId: number, time: number): undefined | Readonly<Transform> | Obtain the transform applied to the model at the specified time point, if any. | |
toJSON(): RenderSchedule.ModelTimelineProps | ||
fromJSON(props?: RenderSchedule.ModelTimelineProps): RenderSchedule.ModelTimeline Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equals(other: RenderSchedule.Timeline): boolean | RenderSchedule.Timeline | |
getAnimationTransform(time: number): Readonly<Transform> | RenderSchedule.Timeline | Get the transform applied to the geometry at the specified time point. |
getClipVector(time: number): undefined | ClipVector | RenderSchedule.Timeline | Create a ClipVector from the CuttingPlane applied to the geometry at the specified time point, if any. |
getColor(time: number): undefined | RgbColor | RenderSchedule.Timeline | Get the color of the geometry at the specified time point, or undefined if the color is not overridden at that time point. |
getCuttingPlane(time: number): undefined | Plane3dByOriginAndUnitNormal | RenderSchedule.Timeline | Get the clipping plane applied to the geometry at the specified time point, or undefined if the geometry is unclipped at that time point. |
getVisibility(time: number): number | RenderSchedule.Timeline | Get the visibility of the geometry at the specified time point. |
Properties
Name | Type | Description | |
---|---|---|---|
containsFeatureOverrides Readonly | boolean | True if this timeline affects the color or transparency of the geometry. | |
containsModelClipping Readonly | boolean | True if this timeline applies clipping to the model. | |
containsTransform Readonly | boolean | True if this timeline affects the position, orientation, or scale of the geometry. | |
elementTimelines Readonly | ReadonlyArray<RenderSchedule.ElementTimeline> | Timelines specifying how to animate groups of GeometricElements within the model. | |
maxBatchId Accessor ReadOnly | number | Get the highest batchId of any ElementTimeline in this timeline. | |
modelId Readonly | string | The Id of the GeometricModel to be animated. | |
omitsElementIds Readonly | boolean | True if any ElementTimelines exist and none of them contain any element Ids. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
color Readonly | RenderSchedule.TimelineEntryList<RenderSchedule.ColorEntry, RenderSchedule.ColorEntryProps, undefined | RgbColor> | undefined | RenderSchedule.Timeline | Sequence controlling the color of the geometry. |
cuttingPlane Readonly | RenderSchedule.TimelineEntryList<RenderSchedule.CuttingPlaneEntry, RenderSchedule.CuttingPlaneEntryProps, undefined | RenderSchedule.CuttingPlane> | undefined | RenderSchedule.Timeline | Sequence controlling how the geometry is clipped. |
duration Readonly | Range1d | RenderSchedule.Timeline | The total time period represented by this timeline. |
transform Readonly | RenderSchedule.TransformTimelineEntries | undefined | RenderSchedule.Timeline | Sequence controlling the position, orientation, and/or scale of the geometry. |
visibility Readonly | RenderSchedule.VisibilityTimelineEntries | undefined | RenderSchedule.Timeline | Sequence controlling the visibility of the geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 855
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.