ProjectExtentsClipDecoration Class
Controls to modify project extents shown using view clip
Extends
Methods
Name | Description | |
---|---|---|
constructor(viewport: ScreenViewport): ProjectExtentsClipDecoration | ||
clearControls(): void Protected | ||
createControls(): Promise<boolean> Protected | The provider is responsible for checking if modification by controls is valid. | |
decorate(context: DecorateContext): void | Sub-classes should override to display the pickable graphics for their controls. | |
drawAreaTooLargeIndicator(context: DecorateContext): void Protected | ||
drawExtentTooLargeIndicator(context: DecorateContext, worldPoint: Point3d, sizePixels: number): void Protected | ||
drawMonumentPoint(context: DecorateContext, point: Point3d, scaleFactor: number, id?: string): void | ||
drawNorthArrow(context: DecorateContext, northDir: Ray3d, id?: string): void | ||
fitExtents(): void | ||
getClockwiseAngleToNorth(): Angle | ||
getDecorationToolTip(hit: HitDetail): Promise<string | HTMLElement> | ||
getModifiedEcefLocation(): undefined | EcefLocation | ||
getModifiedExtents(): undefined | Range3d | ||
getMonumentPoint(): Point3d | ||
getNorthAngle(): Angle | ||
getNorthDirection(refOrigin?: Point3d): Ray3d | ||
hasValidGCS(): boolean Protected | ||
init(): boolean Protected | ||
modifyControls(hit: HitDetail, _ev: BeButtonEvent): Promise<boolean> Protected | A provider can install an InputCollector to support interactive modification. | |
onDecorationButtonEvent(hit: HitDetail, ev: BeButtonEvent): Promise<EventHandled> | Event raised by a PrimitiveTool that supports handle providers to allow a pickable decoration to respond to being located. | |
onManipulatorEvent(eventType: EditManipulator.EventType): void | ||
onRightClick(_hit: HitDetail, _ev: BeButtonEvent): Promise<EventHandled> Protected | Sub-classes can override to present a menu for a right click on a handle. | |
onTouchTap(hit: HitDetail, ev: BeButtonEvent): Promise<EventHandled> Protected | Sub-classes can override to respond to a touch tap on a handle. | |
onViewClose(vp: ScreenViewport): void | ||
resetGeolocation(): boolean | ||
resetViewClip(): boolean | ||
start(): void Protected | ||
stop(): void Protected | Call to clear this handle provider. | |
testDecorationHit(id: string): boolean | ||
updateDecorationListener(_add: boolean): void Protected | Register for decorate event to start displaying control handles. | |
updateEcefLocation(origin: Cartographic, point?: Point3d, angle?: Angle): boolean | ||
updateNorthDirection(northDir: Ray3d): boolean | ||
allowEcefLocationChange(requireExisting: boolean, outputError: booleantrue): boolean Static | ||
clear(clearClip: booleantrue, resetGeolocation: booleantrue): void Static | ||
get(): undefined | ProjectExtentsClipDecoration Static | ||
hide(): void Static | ||
show(vp: ScreenViewport, fitExtents: booleantrue): boolean Static | ||
update(): Promise<void> Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onDoubleClick(_hit: HitDetail, _ev: BeButtonEvent): Promise<EventHandled> Protected Inherited | EditManipulator.HandleProvider | Sub-classes can override to perform some operation for a double click on a handle. |
onManipulatorToolEvent(_tool: Tool, event: ManipulatorToolEvent): void Inherited | EditManipulator.HandleProvider | Event raised by a PrimitiveTool that supports handle providers. |
onSelectionChanged(ev: SelectionSetEvent): void Inherited | EditManipulator.HandleProvider | Event raised by SelectionSet when the active selection changes. |
updateControls(): Promise<void> Protected Inherited | EditManipulator.HandleProvider |
Properties
Name | Type | Description | |
---|---|---|---|
_allowEcefLocationChange Protected | boolean | ||
_clip Protected | ClipVector | undefined | ||
_clipId Protected | string | undefined | ||
_clipRange Protected | Range3d | undefined | ||
_clipShape Protected | ClipShape | undefined | ||
_clipShapeExtents Protected | Range1d | undefined | ||
_controlIds Protected | string[] | ||
_controls Protected | ProjectExtentsControlArrow[] | ||
_ecefLocation Protected | EcefLocation | undefined | ||
_extentsHeightValid Protected | boolean | ||
_extentsLengthValid Protected | boolean | ||
_extentsWidthValid Protected | boolean | ||
_monumentId Protected | string | undefined | ||
_monumentPoint Protected | Point3d | undefined | ||
_northDirection Protected | Ray3d | undefined | ||
_northId Protected | string | undefined | ||
_removeViewCloseListener Protected | () => void | undefined | ||
_suspendDecorator Protected | boolean | ||
maxExtentHeight Accessor Protected ReadOnly | number | Impose some reasonable height limit for project extents. | |
maxExtentLength Accessor Protected ReadOnly | number | Allow project extents for map projections to be larger since curvature of the earth is accounted for. | |
onChanged Readonly | BeEvent<(iModel: IModelConnection, ev: ProjectLocationChanged) => void> | Called when project extents or geolocation is modified | |
suspendGeolocationDecorations | boolean | ||
viewport | ScreenViewport |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_isActive Protected Inherited | boolean | EditManipulator.HandleProvider | |
_removeDecorationListener Protected Inherited | () => void | undefined | EditManipulator.HandleProvider | |
_removeManipulatorToolListener Protected Inherited | () => void | undefined | EditManipulator.HandleProvider | |
_removeSelectionListener Protected Inherited | () => void | undefined | EditManipulator.HandleProvider | |
iModel Inherited | IModelConnection | EditManipulator.HandleProvider |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.