SelectTool Class
Provides UI for selection, delete, move, copy, bring-to-front, send-to-back, etc. for Markup SVG elements
Extends
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): SelectTool | ||
boxSelect(ev: BeButtonEvent, isDynamics: boolean): boolean Protected | ||
boxSelectInit(): void Protected | ||
boxSelectStart(ev: BeButtonEvent): boolean Protected | ||
onCleanup(): Promise<void> | Invoked when the tool becomes no longer active, to perform additional cleanup logic | |
onDataButtonUp(ev: BeButtonEvent): Promise<EventHandled> | Called when there is a mouse "click" (down+up without any motion) | |
onKeyTransition(wentDown: boolean, key: KeyboardEvent): Promise<EventHandled> | called whenever a key is pressed while this tool is active. | |
onModifierKeyTransition(_wentDown: boolean, modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> | called when a modifier key is pressed or released. | |
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> | Called when the mouse goes up after dragging. | |
onMouseMotion(ev: BeButtonEvent): Promise<void> | Called whenever the mouse moves while this tool is active. | |
onMouseStartDrag(ev: BeButtonEvent): Promise<EventHandled> | called when the mouse moves while the data button is down. | |
onPostInstall(): Promise<void> | Override to execute additional logic after tool becomes active | |
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | Invoked when the reset button is released. | |
onRestartTool(): Promise<void> | Called when an external event may invalidate the current tool's state. | |
onTouchTap(ev: BeTouchEvent): Promise<EventHandled> | Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving. | |
showPrompt(): void Protected | ||
unflashSelected(): void Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited | MarkupTool | Used to receive property changes from UI. |
autoLockTarget(): void Inherited | MarkupTool | Called on data button down event to lock the tool to its current target model. |
beginDynamics(): void Inherited | MarkupTool | Call to initialize dynamics mode. |
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited | MarkupTool | Used to "bump" the value of a tool setting. |
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited | MarkupTool | Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled. |
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited | MarkupTool | Helper method for responding to a tool setting property value change by updating saved settings. |
decorate(_context: DecorateContext): void Inherited | MarkupTool | Called to allow an active tool to display non-element decorations in overlay mode. |
decorateSuspended(_context: DecorateContext): void Inherited | MarkupTool | Called to allow a suspended tool to display non-element decorations in overlay mode. |
endDynamics(): void Inherited | MarkupTool | Call to terminate dynamics mode. |
exitTool(): Promise<void> Inherited | MarkupTool | |
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited | MarkupTool | Invoked to allow tools to filter which elements can be located. |
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited | MarkupTool | Fill the supplied button event from the current cursor location. |
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited | MarkupTool | Called to allow snapping to pickable decoration geometry. |
getPrompt(): string Inherited | MarkupTool | Returns the prompt based on the tool's current state. |
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited | MarkupTool | Override to return the property that is disabled/enabled if the supplied property is a lock property. |
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited | MarkupTool | Invoked before the locate tooltip is displayed to retrieve the information about the located element. |
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited | MarkupTool | Helper method to establish initial values for tool setting properties from saved settings. |
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited | MarkupTool | Helper method for tools that need to locate existing elements. |
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean Inherited | MarkupTool | Determine whether the supplied Viewport is compatible with this tool. |
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited | MarkupTool | Checks that the adjusted point from the supplied button event is within the project extents for spatial views. |
onDataButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited | MarkupTool | Invoked when the data button is pressed. |
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited | MarkupTool | Called to allow Tool to display dynamic elements. |
onInstall(): Promise<boolean> Inherited | MarkupTool | Override to execute additional logic when tool is installed. |
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited | MarkupTool | Invoked when the middle mouse button is pressed. |
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited | MarkupTool | Invoked when the middle mouse button is released. |
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited | MarkupTool | Invoked when the mouse wheel moves. |
onRedoPreviousStep(): Promise<boolean> Inherited | MarkupTool | Called to reinstate to a previous tool state (ex. |
onReinitialize(): Promise<void> Inherited | MarkupTool | Called to reset tool to initial state. |
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited | MarkupTool | Invoked when the reset button is pressed. |
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited | MarkupTool | Called when active view changes. |
onSuspend(): Promise<void> Inherited | MarkupTool | Notification of a ViewTool or InputCollector starting and this tool is being suspended. |
onTouchCancel(ev: BeTouchEvent): Promise<void> Inherited | MarkupTool | Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches. |
onTouchComplete(ev: BeTouchEvent): Promise<void> Inherited | MarkupTool | Called when the last touch point is removed from the surface completing the current gesture. |
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited | MarkupTool | Called when user removes a touch point by lifting a finger or stylus from the surface. |
onTouchMove(ev: BeTouchEvent): Promise<void> Inherited | MarkupTool | Called when a touch point moves along the surface. |
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> Inherited | MarkupTool | Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap. |
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited | MarkupTool | Called when user adds a touch point by placing a finger or stylus on the surface. |
onUndoPreviousStep(): Promise<boolean> Inherited | MarkupTool | Called to reverse to a previous tool state (ex. |
onUnsuspend(): Promise<void> Inherited | MarkupTool | Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended. |
outputMarkupPrompt(msg: string): void Protected Inherited | MarkupTool | |
parseAndRun(..._args: string[]): Promise<boolean> Inherited | MarkupTool | Run this instance of a tool using a series of string arguments. |
pickElement(pt: Readonly<WritableXAndY>): undefined | @svgdotjs/svg.js.Element Inherited | MarkupTool | Find the topmost MarkupElement at the specified point in the markup view. |
reloadToolSettingsProperties(): void Inherited | MarkupTool | Called by tool to inform UI to reload ToolSettings with new set of properties. |
requireWriteableTarget(): boolean Inherited | MarkupTool | Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements. |
run(..._args: any[]): Promise<boolean> Inherited | MarkupTool | Establish this tool as the active PrimitiveTool. |
saveChanges(): Promise<void> Inherited | MarkupTool | If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string. |
setCurrentStyle(element: @svgdotjs/svg.js.Element, canBeFilled: boolean): void Protected Inherited | MarkupTool | |
setCurrentTextStyle(element: @svgdotjs/svg.js.Element): void Protected Inherited | MarkupTool | |
setupAndPromptForNextAction(): void Protected Inherited | MarkupTool | |
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited | MarkupTool | Used to supply list of properties that can be used to generate ToolSettings. |
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited | MarkupTool | Called by tool to synchronize the UI with property changes made by tool. |
testDecorationHit(_id: string): boolean Inherited | MarkupTool | Called to support operations on pickable decorations, like snapping. |
register(namespace?: string): void Static Inherited | MarkupTool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
flashedElement Accessor | undefined | @svgdotjs/svg.js.Element | ||
iconSpec Static | string | The icon for this Tool. | |
toolId Static | string | The unique string that identifies this tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
briefcase Accessor Inherited ReadOnly | undefined | BriefcaseConnection | MarkupTool | Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase. |
description Accessor Inherited ReadOnly | string | MarkupTool | Get the localized description string from this Tool's class |
description Accessor Static Inherited ReadOnly | string | MarkupTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, flyover is returned. |
englishKeyin Accessor Static Inherited ReadOnly | string | MarkupTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor Inherited ReadOnly | string | MarkupTool | Get the localized flyover string from this Tool's class |
flyover Accessor Static Inherited ReadOnly | string | MarkupTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, keyin is returned. |
hidden Static Inherited | boolean | MarkupTool | If true, this Tool will not appear in the list from ToolRegistry.getToolList. |
iconSpec Accessor Inherited ReadOnly | string | MarkupTool | Get the iconSpec from this Tool's class. |
iModel Accessor Inherited ReadOnly | IModelConnection | MarkupTool | Get the iModel on which this tool operates. |
isControlDown Accessor Inherited ReadOnly | boolean | MarkupTool | Convenience method to check whether control key is currently down without needing a button event. |
isDynamicsStarted Accessor Inherited ReadOnly | boolean | MarkupTool | Call to find out if dynamics are currently active. |
keyin Accessor Inherited ReadOnly | string | MarkupTool | Get the localized keyin string from this Tool's class |
keyin Accessor Static Inherited ReadOnly | string | MarkupTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
markup Inherited | Markup | MarkupTool | |
maxArgs Accessor Static Inherited ReadOnly | undefined | number | MarkupTool | The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum. If subclasses override parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor Static Inherited ReadOnly | number | MarkupTool | The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static Inherited | string | MarkupTool | The namespace that provides localized strings for this Tool. |
receivedDownEvent Inherited | boolean | MarkupTool | Used to avoid sending tools up events for which they did not receive the down event. |
targetIsLocked Inherited | boolean | MarkupTool | |
targetModelId Accessor Inherited | undefined | string | MarkupTool | |
targetView Inherited | Viewport | undefined | MarkupTool | The viewport within which the tool operates. |
toolId Accessor Inherited ReadOnly | string | MarkupTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolKey Static Inherited | string | MarkupTool |
Defined in
- markup/src/SelectTool.ts Line 512
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.