MarkupTool Class

Base class for all tools that operate on Markup elements.

Extends

Extended by

Methods

Name Description
constructor(..._args: any[]): MarkupTool    
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean Determine whether the supplied Viewport is compatible with this tool.  
onInstall(): Promise<boolean> Override to execute additional logic when tool is installed.  
onPostInstall(): Promise<void> Override to execute additional logic after tool becomes active  
onRestartTool(): Promise<void> Called when an external event may invalidate the current tool's state.  
onTouchCancel(ev: BeTouchEvent): Promise<void> Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.  
onTouchComplete(ev: BeTouchEvent): Promise<void> Called when the last touch point is removed from the surface completing the current gesture.  
onTouchMove(ev: BeTouchEvent): Promise<void> Called when a touch point moves along the surface.  
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.  
onUnsuspend(): Promise<void> Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.  
outputMarkupPrompt(msg: string): void Protected    
pickElement(pt: Readonly<WritableXAndY>): undefined | @svgdotjs/svg.js.Element Find the topmost MarkupElement at the specified point in the markup view.  
requireWriteableTarget(): boolean Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements.  
setCurrentStyle(element: @svgdotjs/svg.js.Element, canBeFilled: boolean): void Protected    
setCurrentTextStyle(element: @svgdotjs/svg.js.Element): void Protected    
setupAndPromptForNextAction(): void Protected    
showPrompt(): void Protected    

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited PrimitiveTool Used to receive property changes from UI.
autoLockTarget(): void Inherited PrimitiveTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void Inherited PrimitiveTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited PrimitiveTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited PrimitiveTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited PrimitiveTool Helper method for responding to a tool setting property value change by updating saved settings.
decorate(_context: DecorateContext): void Inherited PrimitiveTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited PrimitiveTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited PrimitiveTool Call to terminate dynamics mode.
exitTool(): Promise<void> Inherited PrimitiveTool  
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited PrimitiveTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited PrimitiveTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited PrimitiveTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string Inherited PrimitiveTool Returns the prompt based on the tool's current state.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited PrimitiveTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited PrimitiveTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited PrimitiveTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited PrimitiveTool Helper method for tools that need to locate existing elements.
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited PrimitiveTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onCleanup(): Promise<void> Inherited PrimitiveTool Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the data button is pressed.
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited PrimitiveTool Called to allow Tool to display dynamic elements.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited PrimitiveTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited PrimitiveTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the button is released after onMouseStartDrag.
onMouseMotion(_ev: BeButtonEvent): Promise<void> Inherited PrimitiveTool Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the mouse wheel moves.
onRedoPreviousStep(): Promise<boolean> Inherited PrimitiveTool Called to reinstate to a previous tool state (ex.
onReinitialize(): Promise<void> Inherited PrimitiveTool Called to reset tool to initial state.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the reset button is pressed.
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the reset button is released.
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited PrimitiveTool Called when active view changes.
onSuspend(): Promise<void> Inherited PrimitiveTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited PrimitiveTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited PrimitiveTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited PrimitiveTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> Inherited PrimitiveTool Called to reverse to a previous tool state (ex.
parseAndRun(..._args: string[]): Promise<boolean> Inherited PrimitiveTool Run this instance of a tool using a series of string arguments.
reloadToolSettingsProperties(): void Inherited PrimitiveTool Called by tool to inform UI to reload ToolSettings with new set of properties.
run(..._args: any[]): Promise<boolean> Inherited PrimitiveTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> Inherited PrimitiveTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited PrimitiveTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited PrimitiveTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited PrimitiveTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited PrimitiveTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
markup Markup    
toolKey Static string    

Inherited properties

Name Type Inherited from Description
briefcase Accessor Inherited ReadOnly undefined | BriefcaseConnection PrimitiveTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target PrimitiveTool.iModel is a briefcase.
description Accessor Inherited ReadOnly string PrimitiveTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string PrimitiveTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
PrimitiveTool.flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string PrimitiveTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string PrimitiveTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string PrimitiveTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
PrimitiveTool.keyin is returned.
hidden Static Inherited boolean PrimitiveTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string PrimitiveTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string PrimitiveTool The icon for this Tool.
iModel Accessor Inherited ReadOnly IModelConnection PrimitiveTool Get the iModel on which this tool operates.
isControlDown Accessor Inherited ReadOnly boolean PrimitiveTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean PrimitiveTool Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string PrimitiveTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string PrimitiveTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly undefined | number PrimitiveTool The maximum number of arguments allowed by PrimitiveTool.parseAndRun, or undefined if there is no maximum.
If subclasses override PrimitiveTool.parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number PrimitiveTool The minimum number of arguments allowed by PrimitiveTool.parseAndRun. If subclasses override PrimitiveTool.parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string PrimitiveTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean PrimitiveTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked Inherited boolean PrimitiveTool  
targetModelId Accessor Inherited undefined | string PrimitiveTool  
targetView Inherited Viewport | undefined PrimitiveTool The viewport within which the tool operates.
toolId Accessor Inherited ReadOnly string PrimitiveTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
toolId Static Inherited string PrimitiveTool The unique string that identifies this tool.

Defined in

Last Updated: 14 November, 2024