ViewClipByElementTool Class
A tool to define a clip volume for a view using the element aligned box or axis aligned box.
Extends
Methods
Name | Description | |
---|---|---|
constructor(clipEventHandler?: ViewClipEventHandler, _alwaysUseRange: booleanfalse): ViewClipByElementTool | ||
doClipToElements(viewport: Viewport, ids: Id64Arg, alwaysUseRange: booleanfalse, modelId?: string): Promise<boolean> Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited | ViewClipTool | Used to receive property changes from UI. |
autoLockTarget(): void Inherited | ViewClipTool | Called on data button down event to lock the tool to its current target model. |
beginDynamics(): void Inherited | ViewClipTool | Call to initialize dynamics mode. |
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited | ViewClipTool | Used to "bump" the value of a tool setting. |
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited | ViewClipTool | Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled. |
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited | ViewClipTool | Helper method for responding to a tool setting property value change by updating saved settings. |
decorate(_context: DecorateContext): void Inherited | ViewClipTool | Called to allow an active tool to display non-element decorations in overlay mode. |
decorateSuspended(_context: DecorateContext): void Inherited | ViewClipTool | Called to allow a suspended tool to display non-element decorations in overlay mode. |
endDynamics(): void Inherited | ViewClipTool | Call to terminate dynamics mode. |
exitTool(): Promise<void> Inherited | ViewClipTool | |
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited | ViewClipTool | Invoked to allow tools to filter which elements can be located. |
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited | ViewClipTool | Fill the supplied button event from the current cursor location. |
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited | ViewClipTool | Called to allow snapping to pickable decoration geometry. |
getPrompt(): string Inherited | ViewClipTool | Returns the prompt based on the tool's current state. |
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited | ViewClipTool | Override to return the property that is disabled/enabled if the supplied property is a lock property. |
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited | ViewClipTool | Invoked before the locate tooltip is displayed to retrieve the information about the located element. |
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited | ViewClipTool | Helper method to establish initial values for tool setting properties from saved settings. |
initLocateElements(enableLocate: booleantrue, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited | ViewClipTool | Helper method for tools that need to locate existing elements. |
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited | ViewClipTool | Checks that the adjusted point from the supplied button event is within the project extents for spatial views. |
onCleanup(): Promise<void> Inherited | ViewClipTool | Invoked when the tool becomes no longer active, to perform additional cleanup logic |
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited | ViewClipTool | Invoked when the data button is released. |
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited | ViewClipTool | Called to allow Tool to display dynamic elements. |
onInstall(): Promise<boolean> Inherited | ViewClipTool | Override to execute additional logic when tool is installed. |
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited | ViewClipTool | Called when any key is pressed or released. |
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited | ViewClipTool | Invoked when the middle mouse button is pressed. |
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited | ViewClipTool | Invoked when the middle mouse button is released. |
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited | ViewClipTool | Called when Control, Shift, or Alt modifier keys are pressed or released. |
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited | ViewClipTool | Invoked when the button is released after onMouseStartDrag. |
onMouseMotion(_ev: BeButtonEvent): Promise<void> Inherited | ViewClipTool | Invoked when the cursor is moving |
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited | ViewClipTool | Invoked when the cursor begins moving while a button is depressed. |
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited | ViewClipTool | Invoked when the mouse wheel moves. |
onRedoPreviousStep(): Promise<boolean> Inherited | ViewClipTool | Called to reinstate to a previous tool state (ex. |
onReinitialize(): Promise<void> Inherited | ViewClipTool | Called to reset tool to initial state. |
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited | ViewClipTool | Invoked when the reset button is pressed. |
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited | ViewClipTool | Called when active view changes. |
onSuspend(): Promise<void> Inherited | ViewClipTool | Notification of a ViewTool or InputCollector starting and this tool is being suspended. |
onTouchCancel(_ev: BeTouchEvent): Promise<void> Inherited | ViewClipTool | Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches. |
onTouchComplete(_ev: BeTouchEvent): Promise<void> Inherited | ViewClipTool | Called when the last touch point is removed from the surface completing the current gesture. |
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited | ViewClipTool | Called when user removes a touch point by lifting a finger or stylus from the surface. |
onTouchMove(_ev: BeTouchEvent): Promise<void> Inherited | ViewClipTool | Called when a touch point moves along the surface. |
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited | ViewClipTool | Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap. |
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited | ViewClipTool | Called when user adds a touch point by placing a finger or stylus on the surface. |
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited | ViewClipTool | Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving. |
onUndoPreviousStep(): Promise<boolean> Inherited | ViewClipTool | Called to reverse to a previous tool state (ex. |
parseAndRun(..._args: string[]): Promise<boolean> Inherited | ViewClipTool | Run this instance of a tool using a series of string arguments. |
reloadToolSettingsProperties(): void Inherited | ViewClipTool | Called by tool to inform UI to reload ToolSettings with new set of properties. |
run(..._args: any[]): Promise<boolean> Inherited | ViewClipTool | Establish this tool as the active PrimitiveTool. |
saveChanges(): Promise<void> Inherited | ViewClipTool | If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string. |
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited | ViewClipTool | Used to supply list of properties that can be used to generate ToolSettings. |
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited | ViewClipTool | Called by tool to synchronize the UI with property changes made by tool. |
testDecorationHit(_id: string): boolean Inherited | ViewClipTool | Called to support operations on pickable decorations, like snapping. |
areClipsEqual(clipA: ClipVector, clipB: ClipVector): boolean Static Inherited | ViewClipTool | |
doClipClear(viewport: Viewport): boolean Static Inherited | ViewClipTool | |
doClipToConvexClipPlaneSet(viewport: Viewport, planes: ConvexClipPlaneSet): boolean Static Inherited | ViewClipTool | |
doClipToPlane(viewport: Viewport, origin: Point3d, normal: Vector3d, clearExistingPlanes: boolean): boolean Static Inherited | ViewClipTool | |
doClipToRange(viewport: Viewport, range: Range3d, transform?: Transform): boolean Static Inherited | ViewClipTool | |
doClipToShape(viewport: Viewport, xyPoints: Point3d[], transform?: Transform, zLow?: number, zHigh?: number): boolean Static Inherited | ViewClipTool | |
drawClipPlanesLoops(context: DecorateContext, loops: GeometryQuery[], color: ColorDef, weight: number, dashed?: boolean, fill?: ColorDef, id?: string): void Static Inherited | ViewClipTool | |
drawClipShape(context: DecorateContext, shape: ClipShape, extents: Range1d, color: ColorDef, weight: number, id?: string): void Static Inherited | ViewClipTool | |
enableClipVolume(viewport: Viewport): boolean Static Inherited | ViewClipTool | |
hasClip(viewport: Viewport): boolean Static Inherited | ViewClipTool | |
register(namespace?: string): void Static Inherited | ViewClipTool | Register this Tool class with the ToolRegistry. |
setViewClip(viewport: Viewport, clip?: ClipVector): boolean Static Inherited | ViewClipTool |
Properties
Name | Type | Description | |
---|---|---|---|
_alwaysUseRange Protected | boolean | ||
iconSpec Static | string | The icon for this Tool. | |
toolId Static | string | The unique string that identifies this tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_clipEventHandler Protected Inherited | ViewClipEventHandler | undefined | ViewClipTool | |
briefcase Accessor Inherited ReadOnly | undefined | BriefcaseConnection | ViewClipTool | Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase. |
description Accessor Inherited ReadOnly | string | ViewClipTool | Get the localized description string from this Tool's class |
description Accessor Static Inherited ReadOnly | string | ViewClipTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, flyover is returned. |
englishKeyin Accessor Static Inherited ReadOnly | string | ViewClipTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor Inherited ReadOnly | string | ViewClipTool | Get the localized flyover string from this Tool's class |
flyover Accessor Static Inherited ReadOnly | string | ViewClipTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, keyin is returned. |
hidden Static Inherited | boolean | ViewClipTool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor Inherited ReadOnly | string | ViewClipTool | Get the iconSpec from this Tool's class. |
iModel Accessor Inherited ReadOnly | IModelConnection | ViewClipTool | Get the iModel on which this tool operates. |
isControlDown Accessor Inherited ReadOnly | boolean | ViewClipTool | Convenience method to check whether control key is currently down without needing a button event. |
isDynamicsStarted Accessor Inherited ReadOnly | boolean | ViewClipTool | Call to find out if dynamics are currently active. |
keyin Accessor Inherited ReadOnly | string | ViewClipTool | Get the localized keyin string from this Tool's class |
keyin Accessor Static Inherited ReadOnly | string | ViewClipTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
maxArgs Accessor Static Inherited ReadOnly | undefined | number | ViewClipTool | The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum. If subclasses override parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor Static Inherited ReadOnly | number | ViewClipTool | The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static Inherited | string | ViewClipTool | The namespace that provides localized strings for this Tool. |
receivedDownEvent Inherited | boolean | ViewClipTool | Used to avoid sending tools up events for which they did not receive the down event. |
targetIsLocked Inherited | boolean | ViewClipTool | |
targetModelId Accessor Inherited | undefined | string | ViewClipTool | |
targetView Inherited | Viewport | undefined | ViewClipTool | The viewport within which the tool operates. |
toolId Accessor Inherited ReadOnly | string | ViewClipTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.