IModel Class
Represents an iModel in JavaScript.
Implements
Methods
Name | Description | |
---|---|---|
cartographicToSpatialFromEcef(cartographic: Cartographic, result?: Point3d): Point3d | Convert a Cartographic to a point in this iModel's Spatial coordinates using its ecefLocation. | |
ecefToSpatial(ecef: Readonly<WritableXYAndZ>, result?: Point3d): Point3d | Convert a point in ECEF coordinates to a point in this iModel's Spatial coordinates using its ecefLocation. | |
getEcefTransform(): Transform | Get the Transform from this iModel's Spatial coordinates to ECEF coordinates using its ecefLocation. | |
getRpcProps(): IModelRpcProps | Return a token for RPC operations. | |
setEcefLocation(ecef: EcefLocationProps): void | Set the EcefLocation for this iModel. | |
setGeographicCoordinateSystem(geoCRS: GeographicCRSProps): void | Sets the geographic coordinate reference system from GeographicCRSProps. | |
spatialToCartographicFromEcef(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Cartographic | Convert a point in this iModel's Spatial coordinates to a Cartographic using its ecefLocation. | |
spatialToEcef(spatial: Readonly<WritableXYAndZ>, result?: Point3d): Point3d | Convert a point in this iModel's Spatial coordinates to an ECEF point using its ecefLocation. | |
toJSON(): IModelConnectionProps | Convert this iModel to a JSON representation. | |
getDefaultSubCategoryId(categoryId: string): string Static | Get the default subCategoryId for the supplied categoryId |
Properties
Name | Type | Description | |
---|---|---|---|
_openMode Protected | OpenMode | ||
changeset Accessor | ChangesetIdWithIndex | ||
dictionaryId Static Readonly | string | The Id of the dictionary model. | |
ecefLocation Accessor | undefined | EcefLocation | The EcefLocation of the iModel in Earth Centered Earth Fixed coordinates. | |
geographicCoordinateSystem Accessor | undefined | GeographicCRS | The geographic coordinate reference system of the iModel. | |
globalOrigin Accessor | Point3d | An offset to be applied to all spatial coordinates. | |
iModelId Accessor ReadOnly | undefined | string | The Guid that identifies this iModel. | |
isBriefcase Accessor Abstract ReadOnly | boolean | Returns true if this is a briefcase copy of an iModel that is synchronized with iModelHub. |
|
isGeoLocated Accessor ReadOnly | boolean | True if this iModel has an EcefLocation. | |
isOpen Accessor Abstract ReadOnly | boolean | ||
isSnapshot Accessor Abstract ReadOnly | boolean | Returns true if this is a snapshot iModel. |
|
iTwinId Accessor ReadOnly | undefined | string | The Guid that identifies the iTwin that owns this iModel. | |
key Accessor ReadOnly | string | Get the key that was used to open this iModel. | |
name Accessor | string | Name of the iModel | |
onChangesetChanged Readonly | BeEvent<(previousChangeset: ChangesetIdWithIndex) => void> | Event raised after changeset changes. | |
onEcefLocationChanged Readonly | BeEvent<(previousLocation: EcefLocation) => void> | Event raised after ecefLocation changes. | |
onGeographicCoordinateSystemChanged Readonly | BeEvent<(previousGCS: GeographicCRS) => void> | Event raised after geographicCoordinateSystem changes. | |
onGlobalOriginChanged Readonly | BeEvent<(previousOrigin: Point3d) => void> | Event raised after globalOrigin changes. | |
onNameChanged Readonly | BeEvent<(previousName: string) => void> | Event raised after name changes. | |
onProjectExtentsChanged Readonly | BeEvent<(previousExtents: Range3d) => void> | Event raised after projectExtents changes. | |
onRootSubjectChanged Readonly | BeEvent<(previousSubject: RootSubjectProps) => void> | Event raised after rootSubject changes. | |
openMode Accessor ReadOnly | OpenMode | The OpenMode used for this IModel. | |
projectExtents Accessor | Range3d | The volume, in spatial coordinates, inside which the entire project is contained. | |
repositoryModelId Static Readonly | string | The Id of the repository model. | |
rootSubject Accessor | RootSubjectProps | The name and description of the root subject of this iModel | |
rootSubjectId Static Readonly | string | The Id of the root subject element. |
Defined in
- core/common/src/IModel.ts Line 376
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.