IModelProps Interface
Properties of an iModel that are always held in memory whenever one is opened, both on the frontend and on the backend .
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
ecefLocation Readonly | EcefLocationProps | undefined | The location of the iModel in Earth Centered Earth Fixed coordinates. | |
geographicCoordinateSystem Readonly | GeographicCRSProps | undefined | The Geographic Coordinate Reference System indicating the projection and datum used. | |
globalOrigin Readonly | XYZProps | undefined | An offset to be applied to all spatial coordinates. | |
name Readonly | string | undefined | The name of the iModel. | |
projectExtents Readonly | Range3dProps | undefined | The volume of the entire project, in spatial coordinates | |
rootSubject Readonly | RootSubjectProps | The name and description of the root subject of this iModel |
Defined in
- core/common/src/IModel.ts Line 92
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.