OrthographicViewDefinition Class

Defines a spatial view that displays geometry on the image plane using a parallel orthographic projection. See [how to create a OrthographicViewDefinition]$(docs/learning/backend/CreateElements.md#OrthographicViewDefinition).

Extends

Methods

Name Description
constructor(props: SpatialViewDefinitionProps, iModel: IModelDb): OrthographicViewDefinition    
setRange(range: Range3d): void Set a new viewed range without changing the rotation or any other properties.  
create(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso): OrthographicViewDefinition Static Create an OrthographicViewDefinition  
insert(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso): string Static Insert an OrthographicViewDefinition  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited SpatialViewDefinition Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited SpatialViewDefinition Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited SpatialViewDefinition Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited SpatialViewDefinition Call a function for each property of this Entity.
getAuxiliaryCoordinateSystemId(): string Inherited SpatialViewDefinition The Id of the AuxiliaryCoordinateSystem for this ViewDefinition, or an invalid Id if no ACS is defined.
SpatialViewDefinition Get the class metadata for this element.
getDisplayLabel(): string Inherited SpatialViewDefinition Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited SpatialViewDefinition Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited SpatialViewDefinition Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited SpatialViewDefinition Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited SpatialViewDefinition Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited SpatialViewDefinition Get a set of JSON user properties by namespace
insert(): string Inherited SpatialViewDefinition Insert this Element into the iModel.
isDrawingView(): this is DrawingViewDefinition Inherited SpatialViewDefinition Type guard for 'instanceof DrawingViewDefinition'
isSpatialView(): this is SpatialViewDefinition Inherited SpatialViewDefinition Type guard for instanceof SpatialViewDefinition
isView2d(): this is ViewDefinition2d Inherited SpatialViewDefinition Type guard for 'instanceof ViewDefinition2d`
isView3d(): this is ViewDefinition3d Inherited SpatialViewDefinition Type guard for instanceof ViewDefinition3d
loadCategorySelector(): CategorySelector Inherited SpatialViewDefinition Load this view's CategorySelector from the IModelDb.
loadDisplayStyle(): DisplayStyle Inherited SpatialViewDefinition Load this view's DisplayStyle from the IModelDb.
loadDisplayStyle3d(): DisplayStyle3d Inherited SpatialViewDefinition Load this view's DisplayStyle3d from the IModelDb.
loadModelSelector(): ModelSelector Inherited SpatialViewDefinition Load this view's ModelSelector from the IModelDb.
removeUserProperties(nameSpace: string): void Inherited SpatialViewDefinition Remove a set of JSON user properties, specified by namespace, from this Element
setAuxiliaryCoordinateSystemId(acsId: string): void Inherited SpatialViewDefinition Set or clear the AuxiliaryCoordinateSystem for this ViewDefinition.
setJsonProperty(nameSpace: string, value: any): void Inherited SpatialViewDefinition  
setUserProperties(nameSpace: string, value: any): void Inherited SpatialViewDefinition Change a set of user JSON properties of this Element by namespace.
toJSON(): SpatialViewDefinitionProps Inherited SpatialViewDefinition Obtain the JSON representation of this Entity.
update(): void Inherited SpatialViewDefinition Update this Element in the iModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static Inherited SpatialViewDefinition Create a Code for a ViewDefinition given a name that is meant to be unique within the scope of the specified DefinitionModel.
createWithCamera(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso, cameraAngle: numberAngle.piOver2Radians): SpatialViewDefinition Static Inherited SpatialViewDefinition Create a SpatialViewDefinition with the camera turned on.
fromJSON(props: Omit<SpatialViewDefinitionProps, "classFullName">, iModel: IModelDb): SpatialViewDefinition Static Inherited SpatialViewDefinition Construct a SpatialViewDefinition from its JSON representation.
insertWithCamera(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso, cameraAngle: numberAngle.piOver2Radians): string Static Inherited SpatialViewDefinition Insert an SpatialViewDefinition with the camera turned on.
is(otherClass: ): boolean Static Inherited SpatialViewDefinition return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited SpatialViewDefinition Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited SpatialViewDefinition Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited SpatialViewDefinition Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited SpatialViewDefinition Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited SpatialViewDefinition Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited SpatialViewDefinition Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited SpatialViewDefinition Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited SpatialViewDefinition Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited SpatialViewDefinition Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited SpatialViewDefinition Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited SpatialViewDefinition Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited SpatialViewDefinition Called after an element with an instance of this the class as its parent was updated.
onCloned(context: IModelElementCloneContext, sourceElementProps: ViewDefinitionProps, targetElementProps: ViewDefinitionProps): void Protected Static Inherited SpatialViewDefinition  
onDelete(arg: OnElementIdArg): void Protected Static Inherited SpatialViewDefinition Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited SpatialViewDefinition Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited SpatialViewDefinition Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited SpatialViewDefinition Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited SpatialViewDefinition Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited SpatialViewDefinition Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited SpatialViewDefinition Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited SpatialViewDefinition Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited SpatialViewDefinition Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited SpatialViewDefinition Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
angles Inherited YawPitchRollAngles SpatialViewDefinition Rotation from world coordinates to view coordinates.
camera Inherited Camera SpatialViewDefinition The camera used for this view, if cameraOn is true.
cameraOn Inherited boolean SpatialViewDefinition If true, camera is used.
categorySelectorId Inherited string SpatialViewDefinition The element Id of the CategorySelector for this ViewDefinition
classFullName Accessor Inherited ReadOnly string SpatialViewDefinition Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string SpatialViewDefinition Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string SpatialViewDefinition The name of the BIS class associated with this class.
code Inherited Code SpatialViewDefinition The Code for this element
details Accessor Inherited ReadOnly ViewDetails3d SpatialViewDefinition Provides access to optional detail settings for this view.
displayStyleId Inherited string SpatialViewDefinition The element Id of the DisplayStyle for this ViewDefinition
extents Inherited Vector3d SpatialViewDefinition The extent (size) of the view frustum, in meters, along its x,y,z axes.
federationGuid Inherited string | undefined SpatialViewDefinition A FederationGuid assigned to this element by some other federated database
id Inherited string SpatialViewDefinition The Id of this Entity.
iModel Inherited IModelDb SpatialViewDefinition The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" SpatialViewDefinition An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean SpatialViewDefinition If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly Inherited { T } SpatialViewDefinition Optional json properties of this element.
model Readonly Inherited string SpatialViewDefinition The ModelId of the Model containing this element
modelSelectorId Inherited string SpatialViewDefinition The Id of the ModelSelector for this SpatialViewDefinition.
origin Inherited Point3d SpatialViewDefinition The lower left back corner of the view frustum.
parent Inherited RelatedElement | undefined SpatialViewDefinition The parent element, if present, of this element.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray SpatialViewDefinition  
schema Static Inherited SpatialViewDefinition The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string SpatialViewDefinition The name of the BIS Schema that defines this class
userLabel Inherited string | undefined SpatialViewDefinition A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024