Camera Class
The current position (eyepoint), lens angle, and focus distance of a camera.
@see Views
Implements
Methods
Name | Description | |
---|---|---|
constructor(props?: CameraProps): Camera | Construct a Camera | |
clone(): Camera | ||
equals(other: Camera): boolean | ||
getEyePoint(): Point3d | ||
getFocusDistance(): number | ||
getLensAngle(): Angle | ||
invalidateFocus(): void | ||
setEyePoint(pt: Readonly<WritableXYAndZ>): void | ||
setFocusDistance(dist: number): void | ||
setFrom(rhs: Camera): void | ||
setLensAngle(angle: Angle): void | ||
validateLens(): void | ||
isValidLensAngle(val: Angle): boolean Static | ||
validateLensAngle(val: Angle): void Static |
Properties
Name | Type | Description | |
---|---|---|---|
eye Readonly | Point3d | ||
focusDist | number | ||
isFocusValid Accessor ReadOnly | boolean | ||
isLensValid Accessor ReadOnly | boolean | ||
isValid Accessor ReadOnly | boolean | ||
lens Readonly | Angle |
Defined in
- core/common/src/Camera.ts Line 26
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.