ViewDefinition2d Class

Defines a view of a single 2d model. Each 2d model has its own coordinate system, so only one may appear per view.

Extends

Extended by

Methods

Name Description
constructor(props: ViewDefinition2dProps, iModel: IModelDb): ViewDefinition2d Protected    
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Collect the Ids of this entity's references at this level of the class hierarchy.  
loadDisplayStyle2d(): DisplayStyle2d Load this view's DisplayStyle2d from the IModelDb.  
toJSON(): ViewDefinition2dProps Obtain the JSON representation of this Entity.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited ViewDefinition Collect the Ids of this element's references at this level of the class hierarchy.
delete(): void Inherited ViewDefinition Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited ViewDefinition Call a function for each property of this Entity.
getAuxiliaryCoordinateSystemId(): string Inherited ViewDefinition The Id of the AuxiliaryCoordinateSystem for this ViewDefinition, or an invalid Id if no ACS is defined.
ViewDefinition Get the class metadata for this element.
getDisplayLabel(): string Inherited ViewDefinition Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited ViewDefinition Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited ViewDefinition Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited ViewDefinition Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited ViewDefinition Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited ViewDefinition Get a set of JSON user properties by namespace
insert(): string Inherited ViewDefinition Insert this Element into the iModel.
isDrawingView(): this is DrawingViewDefinition Inherited ViewDefinition Type guard for 'instanceof DrawingViewDefinition'
isSpatialView(): this is SpatialViewDefinition Inherited ViewDefinition Type guard for instanceof SpatialViewDefinition
isView2d(): this is ViewDefinition2d Inherited ViewDefinition Type guard for 'instanceof ViewDefinition2d`
isView3d(): this is ViewDefinition3d Inherited ViewDefinition Type guard for instanceof ViewDefinition3d
loadCategorySelector(): CategorySelector Inherited ViewDefinition Load this view's CategorySelector from the IModelDb.
loadDisplayStyle(): DisplayStyle Inherited ViewDefinition Load this view's DisplayStyle from the IModelDb.
removeUserProperties(nameSpace: string): void Inherited ViewDefinition Remove a set of JSON user properties, specified by namespace, from this Element
setAuxiliaryCoordinateSystemId(acsId: string): void Inherited ViewDefinition Set or clear the AuxiliaryCoordinateSystem for this ViewDefinition.
setJsonProperty(nameSpace: string, value: any): void Inherited ViewDefinition  
setUserProperties(nameSpace: string, value: any): void Inherited ViewDefinition Change a set of user JSON properties of this Element by namespace.
update(): void Inherited ViewDefinition Update this Element in the iModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static Inherited ViewDefinition Create a Code for a ViewDefinition given a name that is meant to be unique within the scope of the specified DefinitionModel.
is(otherClass: ): boolean Static Inherited ViewDefinition return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited ViewDefinition Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited ViewDefinition Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited ViewDefinition Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited ViewDefinition Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited ViewDefinition Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited ViewDefinition Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited ViewDefinition Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited ViewDefinition Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited ViewDefinition Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited ViewDefinition Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited ViewDefinition Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited ViewDefinition Called after an element with an instance of this the class as its parent was updated.
onCloned(context: IModelElementCloneContext, sourceElementProps: ViewDefinitionProps, targetElementProps: ViewDefinitionProps): void Protected Static Inherited ViewDefinition  
onDelete(arg: OnElementIdArg): void Protected Static Inherited ViewDefinition Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited ViewDefinition Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited ViewDefinition Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited ViewDefinition Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited ViewDefinition Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited ViewDefinition Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited ViewDefinition Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited ViewDefinition Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited ViewDefinition Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited ViewDefinition Called after an Element was updated.

Properties

Name Type Description
angle Angle The rotation of this view.  
baseModelId string The Id of the Model displayed by this view.  
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
delta Point2d The delta (size) of this view, in meters, aligned with view x,y.  
details Accessor ReadOnly ViewDetails Provides access to optional detail settings for this view.  
origin Point2d The lower-left corner of this view in Model coordinates.  

Inherited properties

Name Type Inherited from Description
categorySelectorId Inherited string ViewDefinition The element Id of the CategorySelector for this ViewDefinition
classFullName Accessor Inherited ReadOnly string ViewDefinition Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string ViewDefinition Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string ViewDefinition The name of the BIS class associated with this class.
code Inherited Code ViewDefinition The Code for this element
displayStyleId Inherited string ViewDefinition The element Id of the DisplayStyle for this ViewDefinition
federationGuid Inherited string | undefined ViewDefinition A FederationGuid assigned to this element by some other federated database
id Inherited string ViewDefinition The Id of this Entity.
iModel Inherited IModelDb ViewDefinition The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" ViewDefinition An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean ViewDefinition If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly Inherited { T } ViewDefinition Optional json properties of this element.
model Readonly Inherited string ViewDefinition The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined ViewDefinition The parent element, if present, of this element.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray ViewDefinition  
schema Static Inherited ViewDefinition The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string ViewDefinition The name of the BIS Schema that defines this class
userLabel Inherited string | undefined ViewDefinition A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024