ViewDefinition2dProps Interface
Parameters used to construct a ViewDefinition2d
Extends
Properties
Name | Type | Description | |
---|---|---|---|
angle | AngleProps | ||
baseModelId | string | ||
delta | XYProps | ||
origin | XYProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categorySelectorId | string | ViewDefinitionProps | |
classFullName | string | ViewDefinitionProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | ViewDefinitionProps | The Code for this element |
description | string | undefined | ViewDefinitionProps | |
displayStyleId | string | ViewDefinitionProps | |
federationGuid | string | undefined | ViewDefinitionProps | A FederationGuid assigned to this element. |
id | string | undefined | ViewDefinitionProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ViewDefinitionProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | boolean | undefined | ViewDefinitionProps | |
jsonProperties | { viewDetails?: ViewDetailsProps } | undefined | ViewDefinitionProps | Optional json properties of this element. |
model | string | ViewDefinitionProps | The Id of the Model containing this element |
parent | RelatedElementProps | undefined | ViewDefinitionProps | The Parent of this element, if defined. |
userLabel | string | undefined | ViewDefinitionProps | A user-assigned label for this element. |
Defined in
- core/common/src/ViewProps.ts Line 205
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.