SpatialViewDefinitionProps Interface
Parameters to construct a SpatialViewDefinition
Extends
Properties
Name | Type | Description | |
---|---|---|---|
modelSelectorId | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
angles | YawPitchRollProps | undefined | ViewDefinition3dProps | Rotation of the view frustum (could be undefined if going Matrix3d -> YawPitchRoll). |
camera | CameraProps | ViewDefinition3dProps | The camera used for this view. |
cameraOn | boolean | ViewDefinition3dProps | if true, camera is valid. |
categorySelectorId | string | ViewDefinition3dProps | |
classFullName | string | ViewDefinition3dProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | ViewDefinition3dProps | The Code for this element |
description | string | undefined | ViewDefinition3dProps | |
displayStyleId | string | ViewDefinition3dProps | |
extents | XYZProps | ViewDefinition3dProps | The extent of the view frustum. |
federationGuid | string | undefined | ViewDefinition3dProps | A FederationGuid assigned to this element. |
id | string | undefined | ViewDefinition3dProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ViewDefinition3dProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | boolean | undefined | ViewDefinition3dProps | |
jsonProperties | { viewDetails?: ViewDetails3dProps } | undefined | ViewDefinition3dProps | Optional json properties of this element. |
model | string | ViewDefinition3dProps | The Id of the Model containing this element |
origin | XYZProps | ViewDefinition3dProps | The lower left back corner of the view frustum. |
parent | RelatedElementProps | undefined | ViewDefinition3dProps | The Parent of this element, if defined. |
userLabel | string | undefined | ViewDefinition3dProps | A user-assigned label for this element. |
Defined in
- core/common/src/ViewProps.ts Line 197
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.