ViewDefinition3dProps Interface
Parameters to construct a ViewDefinition3d
Extends
Properties
Name | Type | Description | |
---|---|---|---|
angles | YawPitchRollProps | undefined | Rotation of the view frustum (could be undefined if going Matrix3d -> YawPitchRoll). | |
camera | CameraProps | The camera used for this view. | |
cameraOn | boolean | if true, camera is valid. | |
extents | XYZProps | The extent of the view frustum. | |
jsonProperties | { viewDetails?: ViewDetails3dProps } | undefined | Optional json properties of this element. | |
origin | XYZProps | The lower left back corner of the view frustum. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categorySelectorId | string | ViewDefinitionProps | |
classFullName | string | ViewDefinitionProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | ViewDefinitionProps | The Code for this element |
description | string | undefined | ViewDefinitionProps | |
displayStyleId | string | ViewDefinitionProps | |
federationGuid | string | undefined | ViewDefinitionProps | A FederationGuid assigned to this element. |
id | string | undefined | ViewDefinitionProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ViewDefinitionProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | boolean | undefined | ViewDefinitionProps | |
model | string | ViewDefinitionProps | The Id of the Model containing this element |
parent | RelatedElementProps | undefined | ViewDefinitionProps | The Parent of this element, if defined. |
userLabel | string | undefined | ViewDefinitionProps | A user-assigned label for this element. |
Defined in
- core/common/src/ViewProps.ts Line 176
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.