ViewDetails3d Class
Encapsulates access to optional 3d view details stored in JSON properties.
@see ViewDetails3dProps for the JSON representation.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
allow3dManipulations Accessor | boolean | Controls whether viewing tools are allowed to operate on the view in 3 dimensions. | |
modelClipGroups Accessor | ModelClipGroups | Groups of models associated with ClipVectors by which those models should be clipped. | |
onModelClipGroupsChanged Readonly | BeEvent<(newGroups: ModelClipGroups) => void> | Event raised when just before assignment to the modelClipGroups property. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
aspectRatioSkew Accessor | number | ViewDetails | The aspect ratio skew (x/y, usually 1.0) used to exaggerate the y axis of the view. |
auxiliaryCoordinateSystemId Accessor | string | ViewDetails | The Id of the auxiliary coordinate system for the view. |
clipVector Accessor | undefined | ClipVector | ViewDetails | Clipping volume for the view. |
gridOrientation Accessor | GridOrientationType | ViewDetails | The orientation of the view's grid. |
gridSpacing Accessor | Readonly<WritableXAndY> | ViewDetails | The grid spacing for the view. |
gridsPerRef Accessor | number | ViewDetails | The number of grids per ref for the view. |
maxSkew Static | number | ViewDetails | Maximum aspect ratio skew. |
onClipVectorChanged Readonly | BeEvent<(newClip: ClipVector) => void> | ViewDetails | Event raised just before assignment to the clipVector property. |
Defined in
- core/common/src/ViewDetails.ts Line 181
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.