LinearLocation Class

Linear Referencing Location attached to an Element not inherently Linearly Referenced.

Extends

Implements

Methods

Name Description
constructor(props: GeometricElement3dProps, iModel: IModelDb): LinearLocation    
insertAt(iModel: IModelDb, linearElementId: string, atPosition: LinearlyReferencedAtLocationProps, locatedElementId: string): string    
insertFromTo(iModel: IModelDb, linearElementId: string, fromToPosition: LinearlyReferencedFromToLocationProps, locatedElementId: string): string    
create(iModel: IModelDb, modelId: string, categoryId: string): LinearLocation Static    
insertAt(iModel: IModelDb, modelId: string, categoryId: string, linearElementId: string, atPosition: LinearlyReferencedAtLocationProps, locatedElementId: string): string Static    
insertFromTo(iModel: IModelDb, modelId: string, categoryId: string, linearElementId: string, fromToPosition: LinearlyReferencedFromToLocationProps, locatedElementId: string): string Static    

Inherited methods

Name Inherited from Description
calculateRange3d(): Range3d Inherited LinearLocationElement  
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited LinearLocationElement Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited LinearLocationElement  
delete(): void Inherited LinearLocationElement Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom?: boolean): void Inherited LinearLocationElement Call a function for each property of this Entity.
LinearLocationElement Get the class metadata for this element.
getDisplayLabel(): string Inherited LinearLocationElement Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited LinearLocationElement Get a JSON property of this element, by namespace
getLinearElementId(): undefined | string Inherited LinearLocationElement  
getPlacementTransform(): Transform Inherited LinearLocationElement Get the Transform from the Placement of this GeometricElement
getPredecessorIds(): Id64Set Inherited LinearLocationElement Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited LinearLocationElement Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited LinearLocationElement Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited LinearLocationElement Get a set of JSON user properties by namespace
insert(): string Inherited LinearLocationElement Insert this Element into the iModel.
is2d(): this is GeometricElement2d Inherited LinearLocationElement Type guard for instanceof GeometricElement2d
is3d(): this is GeometricElement3d Inherited LinearLocationElement Type guard for instanceof GeometricElement3d
removeUserProperties(nameSpace: string): void Inherited LinearLocationElement Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited LinearLocationElement  
setUserProperties(nameSpace: string, value: any): void Inherited LinearLocationElement Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricElement3dProps Inherited LinearLocationElement  
update(): void Inherited LinearLocationElement Update this Element in the iModel.
is(otherClass: ): boolean Static Inherited LinearLocationElement return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited LinearLocationElement Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited LinearLocationElement Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited LinearLocationElement Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited LinearLocationElement Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited LinearLocationElement Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited LinearLocationElement Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited LinearLocationElement Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited LinearLocationElement Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited LinearLocationElement Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited LinearLocationElement Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited LinearLocationElement Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited LinearLocationElement Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited LinearLocationElement Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited LinearLocationElement Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited LinearLocationElement Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited LinearLocationElement Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited LinearLocationElement Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited LinearLocationElement Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited LinearLocationElement Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited LinearLocationElement Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited LinearLocationElement Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited LinearLocationElement Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited LinearLocationElement Called after an Element was updated.

Inherited properties

Name Type Inherited from Description
category Inherited string LinearLocationElement The Id of the Category for this GeometricElement.
classFullName Accessor Inherited ReadOnly string LinearLocationElement Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string LinearLocationElement Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string LinearLocationElement The name of the BIS class associated with this class.
code Inherited Code LinearLocationElement The Code for this element
elementGeometryBuilderParams Inherited ElementGeometryBuilderParams | undefined LinearLocationElement How to build the element's GeometryStream.
federationGuid Inherited string | undefined LinearLocationElement A FederationGuid assigned to this element by some other federated database
geom Inherited GeometryStreamProps | undefined LinearLocationElement The GeometryStream for this GeometricElement.
id Inherited string LinearLocationElement The Id of this Entity.
iModel Inherited IModelDb LinearLocationElement The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" LinearLocationElement An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly Inherited { T } LinearLocationElement Optional json properties of this element.
model Readonly Inherited string LinearLocationElement The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined LinearLocationElement The parent element, if present, of this element.
placement Inherited Placement3d LinearLocationElement The origin, orientation, and bounding box of this GeometricElement.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray LinearLocationElement  
schema Static Inherited LinearLocationElement The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string LinearLocationElement The name of the BIS Schema that defines this class
typeDefinition Inherited TypeDefinition | undefined LinearLocationElement  
userLabel Inherited string | undefined LinearLocationElement A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024