GeometricElement3dProps Interface
Properties that define a GeometricElement3d
Extends
Properties
Name | Type | Description | |
---|---|---|---|
placement | Placement3dProps | undefined | The placement properties | |
typeDefinition | RelatedElementProps | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category | string | GeometricElementProps | The id of the category for this geometric element. |
classFullName | string | GeometricElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | GeometricElementProps | The Code for this element |
elementGeometryBuilderParams | ElementGeometryBuilderParams | undefined | GeometricElementProps | Describes how to build the element's GeometryStream, as an alternative to geom. |
federationGuid | string | undefined | GeometricElementProps | A FederationGuid assigned to this element. |
geom | GeometryStreamProps | undefined | GeometricElementProps | The geometry stream properties |
id | string | undefined | GeometricElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | GeometricElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | any | undefined | GeometricElementProps | Optional json properties of this element. |
model | string | GeometricElementProps | The Id of the Model containing this element |
parent | RelatedElementProps | undefined | GeometricElementProps | The Parent of this element, if defined. |
userLabel | string | undefined | GeometricElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 162
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.