MaskBackgroundMapByExcludedElementTool Class

Tool to mask background map by excluded elements

Extends

Methods

Name Description
constructor(..._args: any[]): MaskBackgroundMapByExcludedElementTool    
applyMask(vp: ScreenViewport): void Protected    
createToolInstance(): PlanarMaskBaseTool Protected    
showPrompt(): void Protected    
targetModelRequired(): boolean Protected    

Inherited methods

Name Inherited from Description
allowSelection(): boolean Protected Inherited PlanarMaskBaseTool  
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited PlanarMaskBaseTool Used to receive property changes from UI.
autoLockTarget(): void Inherited PlanarMaskBaseTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void Inherited PlanarMaskBaseTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited PlanarMaskBaseTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited PlanarMaskBaseTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited PlanarMaskBaseTool Helper method for responding to a tool setting property value change by updating saved settings.
createElementMask(option: "include" | "exclude"): PlanarClipMaskSettings Protected Inherited PlanarMaskBaseTool  
createModelMask(): PlanarClipMaskSettings Protected Inherited PlanarMaskBaseTool  
createSubCategoryMask(): PlanarClipMaskSettings Protected Inherited PlanarMaskBaseTool  
decorate(_context: DecorateContext): void Inherited PlanarMaskBaseTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited PlanarMaskBaseTool Called to allow a suspended tool to display non-element decorations in overlay mode.
elementRequired(): boolean Protected Inherited PlanarMaskBaseTool  
endDynamics(): void Inherited PlanarMaskBaseTool Call to terminate dynamics mode.
exitTool(): Promise<void> Inherited PlanarMaskBaseTool  
filterHit(hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited PlanarMaskBaseTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited PlanarMaskBaseTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited PlanarMaskBaseTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string Inherited PlanarMaskBaseTool Returns the prompt based on the tool's current state.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited PlanarMaskBaseTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited PlanarMaskBaseTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited PlanarMaskBaseTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited PlanarMaskBaseTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean Inherited PlanarMaskBaseTool Determine whether the supplied Viewport is compatible with this tool.
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited PlanarMaskBaseTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onCleanup(): Promise<void> Inherited PlanarMaskBaseTool Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the data button is pressed.
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited PlanarMaskBaseTool Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> Inherited PlanarMaskBaseTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the button is released after onMouseStartDrag.
onMouseMotion(_ev: BeButtonEvent): Promise<void> Inherited PlanarMaskBaseTool Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the mouse wheel moves.
onPostInstall(): Promise<void> Inherited PlanarMaskBaseTool Override to execute additional logic after tool becomes active
onRedoPreviousStep(): Promise<boolean> Inherited PlanarMaskBaseTool Called to reinstate to a previous tool state (ex.
onReinitialize(): Promise<void> Inherited PlanarMaskBaseTool Called to reset tool to initial state.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the reset button is pressed.
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Invoked when the reset button is released.
onRestartTool(): Promise<void> Inherited PlanarMaskBaseTool Called when an external event may invalidate the current tool's state.
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited PlanarMaskBaseTool Called when active view changes.
onSuspend(): Promise<void> Inherited PlanarMaskBaseTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(_ev: BeTouchEvent): Promise<void> Inherited PlanarMaskBaseTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(_ev: BeTouchEvent): Promise<void> Inherited PlanarMaskBaseTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited PlanarMaskBaseTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(_ev: BeTouchEvent): Promise<void> Inherited PlanarMaskBaseTool Called when a touch point moves along the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited PlanarMaskBaseTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited PlanarMaskBaseTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> Inherited PlanarMaskBaseTool Called to reverse to a previous tool state (ex.
onUnsuspend(): Promise<void> Inherited PlanarMaskBaseTool Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.
parseAndRun(...args: string[]): Promise<boolean> Inherited PlanarMaskBaseTool Run this instance of a tool using a series of string arguments.
reloadToolSettingsProperties(): void Inherited PlanarMaskBaseTool Called by tool to inform UI to reload ToolSettings with new set of properties.
requireWriteableTarget(): boolean Inherited PlanarMaskBaseTool Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements.
run(..._args: any[]): Promise<boolean> Inherited PlanarMaskBaseTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> Inherited PlanarMaskBaseTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
setRealityModelMask(vp: ScreenViewport, mask: PlanarClipMaskSettings): void Protected Inherited PlanarMaskBaseTool  
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited PlanarMaskBaseTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited PlanarMaskBaseTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited PlanarMaskBaseTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited PlanarMaskBaseTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
maxArgs Accessor Static ReadOnly number The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.  
minArgs Accessor Static ReadOnly number The minimum number of arguments allowed by parseAndRun.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
_acceptedElementIds Protected Readonly Inherited Set<string> PlanarMaskBaseTool  
_acceptedModelIds Protected Readonly Inherited Set<string> PlanarMaskBaseTool  
_acceptedSubCategoryIds Protected Readonly Inherited Set<string> PlanarMaskBaseTool  
_invert Protected Inherited boolean PlanarMaskBaseTool  
_targetMaskModel Protected Inherited string | ContextRealityModelState PlanarMaskBaseTool  
_transparency Protected Inherited number PlanarMaskBaseTool  
_useSelection Protected Inherited boolean PlanarMaskBaseTool  
briefcase Accessor Inherited ReadOnly undefined | BriefcaseConnection PlanarMaskBaseTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase.
description Accessor Inherited ReadOnly string PlanarMaskBaseTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string PlanarMaskBaseTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string PlanarMaskBaseTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string PlanarMaskBaseTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string PlanarMaskBaseTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean PlanarMaskBaseTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string PlanarMaskBaseTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string PlanarMaskBaseTool The icon for this Tool.
iModel Accessor Inherited ReadOnly IModelConnection PlanarMaskBaseTool Get the iModel on which this tool operates.
isControlDown Accessor Inherited ReadOnly boolean PlanarMaskBaseTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean PlanarMaskBaseTool Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string PlanarMaskBaseTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string PlanarMaskBaseTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
namespace Static Inherited string PlanarMaskBaseTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean PlanarMaskBaseTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked Inherited boolean PlanarMaskBaseTool  
targetModelId Accessor Inherited undefined | string PlanarMaskBaseTool  
targetView Inherited Viewport | undefined PlanarMaskBaseTool The viewport within which the tool operates.
toolId Accessor Inherited ReadOnly string PlanarMaskBaseTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 14 November, 2024