Pixel.Data Class
Describes a single pixel within a Pixel.Buffer.
Methods
Name | Description | |
---|---|---|
computeHitPriority(): HitPriority | Computes the HitPriority of this pixel based on its Pixel.Data.type and Pixel.Data.planarity. | |
toHitProps(viewport: Viewport): Pixel.HitProps | Convert this pixel to a HitProps suitable for constructing a HitDetail. |
Properties
Name | Type | Description | |
---|---|---|---|
distanceFraction Readonly | number | The pixel's depth in CoordSystem.Npc coordinates (0 to 1), or -1 if depth was not written or not requested. | |
elementId Accessor ReadOnly | undefined | string | The Id of the element that produced the pixel. | |
feature Readonly | Feature | undefined | The feature that produced the pixel. | |
geometryClass Accessor ReadOnly | undefined | GeometryClass | The class of geometry that produced the pixel. | |
iModel Readonly | IModelConnection | undefined | The iModel from which the geometry producing the pixel originated. | |
inSectionDrawingAttachment Readonly | boolean | True if the pixel originated from a SpatialViewState attached via a SectionDrawing. | |
modelId Readonly | string | undefined | ||
planarity Readonly | Pixel.Planarity | The planarity of the geometry that produced the pixel. | |
subCategoryId Accessor ReadOnly | undefined | string | The Id of the SubCategory that produced the pixel. | |
type Readonly | Pixel.GeometryType | The type of geometry that produced the pixel. | |
viewAttachmentId Readonly | string | undefined | The Id of the ViewAttachment, if any, from which the pixel originated. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.