SectionDrawingModelState Class

Represents the front-end state of a SectionDrawingModel.

Extends

Methods

Name Description
constructor(props: GeometricModel2dProps, iModel: IModelConnection, state?: GeometricModel2dState): SectionDrawingModelState    

Inherited methods

Name Inherited from Description
clone(iModel?: IModelConnection): this Inherited DrawingModelState Make an independent copy of this EntityState
equals(other: this): boolean Inherited DrawingModelState Return true if this EntityState is equal to another one.
queryModelRange(): Promise<Range3d> Inherited DrawingModelState Query for the union of the ranges of all the elements in this GeometricModel.
toJSON(): GeometricModel2dProps Inherited DrawingModelState Add all custom-handled properties of a Model to a json object.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
asGeometricModel Accessor Inherited ReadOnly GeometricModelState DrawingModelState Attempts to cast this model to a geometric model.
asGeometricModel2d Accessor Inherited ReadOnly GeometricModel2dState DrawingModelState Attempts to cast this model to a 2d geometric model.
asGeometricModel3d Accessor Inherited ReadOnly undefined | GeometricModel3dState DrawingModelState Attempts to cast this model to a 3d geometric model.
asSpatialModel Accessor Inherited ReadOnly undefined | SpatialModelState DrawingModelState Attempts to cast this model to a spatial model.
classFullName Accessor Static Inherited ReadOnly string DrawingModelState Get full BIS class name of this Entity in the form "SchemaName:ClassName".
classFullName Readonly Inherited string DrawingModelState The full class name in the form "schema:class".
className Accessor Inherited ReadOnly string DrawingModelState The name of the BIS class associated with this class.
id Readonly Inherited string DrawingModelState The Id of this Entity.
iModel Readonly Inherited IModelConnection DrawingModelState The iModel from which this Entity was loaded
is2d Accessor Inherited ReadOnly boolean DrawingModelState Returns true if this is a 2d model (a GeometricModel2dState).
is3d Accessor Inherited ReadOnly boolean DrawingModelState Returns true if this is a 3d model (a GeometricModel3dState).
isGeometricModel Accessor Inherited ReadOnly boolean DrawingModelState Determine whether this is a GeometricModel
isPrivate Readonly Inherited boolean DrawingModelState  
isTemplate Readonly Inherited boolean DrawingModelState  
jsonProperties Readonly Inherited { T } DrawingModelState Optional json properties of this Entity.
modeledElement Readonly Inherited RelatedElement DrawingModelState  
name Readonly Inherited string DrawingModelState  
parentModel Inherited string DrawingModelState  
schemaName Accessor Static Inherited ReadOnly string DrawingModelState The name of the BIS schema for this class.

Defined in

Last Updated: 14 November, 2024